Win a copy of Microservices Testing (Live Project) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

tomcat is not running in eclipse

 
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi all!

I have tomcat5.5,eclipse3.3 Europa and linux fedora 6. I have configured my application and set server as tomcat. Still when I am giving url http://localhost:8080 it is not working and showing error-

HTTP Status 404 - /

type Status report

message /

description The requested resource (/) is not available.
Apache Tomcat/5.5.25


whats wrong?
 
Saloon Keeper
Posts: 25794
184
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Tomcat [i]is[/b] working. You even got an error message from it, telling you that you are running Tomcat Version 5.5.25.

However you don't have a default webapp installed or if you do, it has no default ("hello") page.

Usually you'll have bound your webapp to a non-default web application Context, so your URLs would look more like "http://localhost:8080/mywebapp/hello.jsp".
 
abhijeet srivastava
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks. Its working on giving full application file path like-

http://localhost:8080/Test/Hello.jsp

but its not showing home page of tomcat on giving-

http://localhost:8080

before running tomcat in eclipse it was showing.
but now nor external tomcat home page is running nor eclipse's internal though on giving full path of file of any application it is perfectly fine.

where to configure for showing tomcat home page?
 
Marshal
Posts: 27278
87
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by abhijeet srivastava:
where to configure for showing tomcat home page?

We have a Apache/Tomcat forum. Let's try asking this question there.
 
Greenhorn
Posts: 29
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

before running tomcat in eclipse it was showing.
but now nor external tomcat home page is running nor eclipse's internal though on giving full path of file of any application it is perfectly fine.


eclipse has modified the server.xml of your tomcat.
Sorry to say that, but I don't think that there is a way to restore your orig. configuration.
You should not use a TC that is used for other than devevlopment purposes from within eclipse.

You can configure if eclipse should modify you installation or not in the server settings in eclipse.
reply
    Bookmark Topic Watch Topic
  • New Topic