• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
Sheriffs:
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
Bartenders:
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

Error with Tomcat 6

 
Ranch Hand
Posts: 76
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I run Windows Vista Home Premium.

I recently installed Apache Tomcat 6.0.14 and it seems to have problems running even the most basic JSP applications (I'm talking "Hello World" here). It runs Servlets perfectly, but cannot run any JSP apps.

It says there is an "internal server error" with a HTTP 500 status.

The logs reveal this:

org.apache.catalina.core.StandardContextValve invoke
SEVERE: Exception sending request destroyed lifecycle event to listener instance of class com.sun.faces.config.ConfigureListener
java.lang.NullPointerException
at com.sun.faces.application.WebappLifecycleListener.syncSessionScopedBeans(WebappLifecycleListener.java:312)
at com.sun.faces.application.WebappLifecycleListener.requestDestroyed(WebappLifecycleListener.java:87)
at com.sun.faces.config.ConfigureListener.requestDestroyed(ConfigureListener.java:240)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:263)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:584)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
at java.lang.Thread.run(Unknown Source)


The stack trace is exactly the same whenever I try to run a JSP app. The funny thing is, the apps ran fine when I first tried to run them after installing Tomcat. The trouble (I think) is when I restart the service after deploying some new stuff onto the webapps folder. I know this because I reinstalled Tomcat and the apps started working again, only to give me the aforementioned error after a while.

What must I do to resolve this? I don't want to keep reinstalling Tomcat every time I want to run a JSP app! Any help is greatly appreciated.

P.S. I turned user account control off and ticked both "service" and "native" while installing Tomcat through the Windows installer, if that's of any consequence.
[ December 24, 2007: Message edited by: Bear Bibeault ]
 
reply
    Bookmark Topic Watch Topic
  • New Topic