• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Tomcat 6.0 and Axis 1.4 XML Security Error

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Guys,

Working on a project, I am experiencing problems working with Tomcat 6.0 together with Axis 1.4. My Java version is jre1.6.0_0

I installed Tomcat 6.0 in a folder in my C Drive on Vista HP called Tomcat. so in the Tomcat folder is a folder called Tomcat 6.0. I can acces Tomcat by localhost:8080

I downloaded axis 1.4 and extracted it in the webapp folder of Tomcat. So there is a folder called axis in the webapp folder of Tomcat. I can acces axis by going to localhost:8080/axis/

Everything worked fine except for 2 things. The Javamail and the XML security optional component. I downloaded javamail and did put the mail.jar file in the lib folder of Tomcat. That worked fine.

So here is my real problem. The XML security ( http://xml.apache.org/security/ ) will not work. But for the project I am working on, the XML security is a requirement. I downloaded XML security bin 1.4.1 from http://xml.apache.org/security/dist/java-library/ and put the xmlsec-1.4.1.jar file in the Tomcat lib folder. I got the following error on the validation page:

Warning: could not find a dependency of class org.apache.xml.security.Init from file XML Security is not supported.

See http://xml.apache.org/security/ {4}
The root cause was: org/apache/commons/logging/LogFactory
This can happen e.g. if org.apache.xml.security.Init is in the 'common' classpath, but a dependency like activation.jar is only in the webapp classpath.

Underneath came the following message: Found Java Secure Socket Extension ( javax.net.ssl.SSLSocketFactory ) at an unknown location

I tried everything, downloading the previous XML security bins, version 1.1.0, 1.2.0, 1.3.0, 1.3.1 and 1.4.0 but I still get the error.

My question is: How can I get XML security working? What are the steps I have to take?
 
Rancher
Posts: 43081
77
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Welcome to JavaRanch.

It's been a while since I last used Axis 1, but there's more to getting security to work than just deploying the XML-Sec jar. You need all the jar files that are part of WSS4J.

The article Web Services Authentication with Axis 2 (written by yours truly) should also be helpful.
 
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Axis ships with a test JSP page that checks for all of the jars.
It's called happAxis.jsp or something like that.
Look for it in the root directory of the axis application.
 
reply
    Bookmark Topic Watch Topic
  • New Topic