Win a copy of 97 Things Every Java Programmer Should Know this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

problem in running tomcat server

 
Ranch Hand
Posts: 97
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi actually i have oracle installed on my computer which has oracle http server and i also have apache tomcat server in my computer.But when i am trying to connect to apache tomcat server it shows

[ The server localhost at XDB requires a username and password error.Warning: This server is requesting that your username and password be sent in an insecure manner (basic authentication without a secure connection)].

Before when i was not installed oracle i can easily connect to tomcat sever.Can any one tell me why this option is showing.?
thanks in advance
[ August 18, 2008: Message edited by: manas ranjan mandal ]
 
Ranch Hand
Posts: 1179
Mac OS X Eclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You need to change the Tomcat default port '8080' or the Oracle XDB default port '8080'

You can here see how to change the Oracle default ports (XDB and FTP): XML DB Port Assignments
 
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oracle apps run as a windows services, you can try to disable the services and see.it should work.
 
manas ranjan mandal
Ranch Hand
Posts: 97
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks now my problem is resolved.Actually i changed the tomcat server port no 8080 to 8081 during installation.
 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
solving xdb problem


1).goto C:\apache tomcat 8.0.5\conf
2)you will find server.xml Right click on it and open with text editor

3) after scrolling page you will find this lines [line no 68]

<Connector port="8080" protocol="HTTP/1.1"
connectionTimeout="20000"
redirectPort="8443" />

4) rename port name from 8080 to 8081 and in browser type http://localhost:8081/

<Connector port="8081" protocol="HTTP/1.1"
connectionTimeout="20000"
redirectPort="8443" />
 
Arch enemy? I mean, I don't like you, but I don't think you qualify as "arch enemy". Here, try this tiny ad:
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic