• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Liutauras Vilda
  • Paul Clapham
Sheriffs:
  • paul wheaton
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Piet Souris
Bartenders:
  • Mike London

Can't Get SSL/HTTPS To Work

 
Ranch Hand
Posts: 327
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm trying to get HTTPS to work for my JBoss/Tomcat. I generated a key store and also did the following but it does not work.

I added to C:\java\jboss-3.2.1_tomcat-4.1.24\server\default\deploy\jbossweb-tomcat.sar\META-INF\jboss-service.xml the following:



I know that I need to add something like the following somewhere, but I don't know where:



Please give me some guidance on this. I am using JBoss 3.2.1. Any help would be greatly appreciated as I am feeling like and like and like
[ July 08, 2004: Message edited by: Anthony Watson ]
 
Anthony Watson
Ranch Hand
Posts: 327
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
After much torture, I figured out that JBoss was failing to start properly because it couldn't find the keystore. To enable https/ssl, you just need to create a keystore. I put mine in jboss-3.2.1_tomcat-4.1.24\server\default\conf. Then, go to the jboss-3.2.1_tomcat-4.1.24\server\default\deploy\jbossweb-tomcat.sar\META-INF file and insert the following xml below the regular http connector xml:
reply
    Bookmark Topic Watch Topic
  • New Topic