• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Tim Cooke
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Paul Clapham
  • Rob Spoor
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
  • Carey Brown
Bartenders:

JBoss Language problem

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Folks,

I am a newbies using the JBoss 4.0.

My company is based in HK and all my work is related to Chinese.

However, I find that there is a lot of encoding problem when I write a JSP page with Chinese Characters to be displayed.

Anyone can advices how to set the default encoding of the server?

I am able to display the Chinese character when I set the JSP as follows

<%@ page language="java" pageEncoding="BIG5" contentType="text/html; charset=UTF8"%>

I am using Eclipse as the IDE for writing the JSP page

However, when I wanna to display a variables which stores Chinese character, using <%= character %>, the word is broken and I don't know how to do.

Can anyone please help

Thanks
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic