• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
Sheriffs:
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
Bartenders:
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

Unable to access application on JBoss 3.2.3

 
Ranch Hand
Posts: 360
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I have created a web project using WSAD 5.0 and created a ear file using export function. Later I deployed this ear file to JBoss. I copied the file into C:\JBoss-3.2.3\server\default\deploy directory.The sever.log showing below information. I'm getting Page Not Found message when I try to access this application using url http://<ipaddressofmymachine>/Monitor/Main

I really appreciate anu suggestions. Thanks much

INFO [org.jboss.deployment.MainDeployer] Starting deployment of package: file:/C:/JBoss-3.2.3/server/default/deploy/EnterpriseApps.ear

INFO [org.jboss.deployment.EARDeployer] Init J2EE application: file:/C:/JBoss-3.2.3/server/default/deploy/EnterpriseApps.ear

INFO [org.jboss.web.tomcat.tc4.EmbeddedTomcatService] deploy, ctxPath=/Monitor, warUrl=file:/C:/JBoss-3.2.3/server/default/tmp/deploy/tmp52018EnterpriseApps.ear-contents/Monitor.war/

INFO [org.jboss.web.localhost.Engine] SingleSignOnContextConfig[/Monitor]: Added certificates -> request attribute Valve

Unable to invoke setDelegate on class loader rg.jboss.web.tomcat.tc4.WebCtxLoader$ENCLoader@2ba

INFO [org.jboss.web.localhost.Engine] StandardManager[/Monitor]: Seeding random number generator class java.security.SecureRandom

INFO [org.jboss.web.localhost.Engine] StandardManager[/Monitor]: Seeding of random number generator has been completed

INFO [org.jboss.web.localhost.Engine] StandardWrapper[/Monitor efault]: Loading container servlet default

INFO [org.jboss.web.localhost.Engine] StandardWrapper[/Monitor:invoker]: Loading container servlet invoker

INFO [org.jboss.deployment.EARDeployer] Started J2EE application: file:/C:/JBoss-3.2.3/server/default/deploy/EnterpriseApps.ear

INFO [org.jboss.deployment.MainDeployer] Deployed package: file:/C:/JBoss-3.2.3/server/default/deploy/EnterpriseApps.ear

INFO [org.jboss.deployment.scanner.URLDeploymentScanner] Started jboss.deployment:type=DeploymentScanner,flavor=URL

INFO [org.jboss.deployment.MainDeployer] Deployed package: file:/C:/JBoss-3.2.3/server/default/conf/jboss-service.xml
 
Dilip kumar
Ranch Hand
Posts: 360
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It is working if I use http://<ipaddressofmymachine>:8080/Monitor/Main

Wondering how to make application work without putting the port 8080

Thanks
 
Ranch Hand
Posts: 70
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi!
Assuming you're using the default settings, the 8080 part is in the tomcat configuration. In server/default/deploy/ there's probably a folder that ends in .sar. in that, there's META-INF. you should be able to tweek the port in there. If you make 8080 to 80, you won't need the port piece of the URL you were using.

Good luck!

--Jeff
 
Ranch Hand
Posts: 75
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dilip
are you able to resolve the issue. Share the info if you did.
thanks a bunch
Sirisha.
 
Ranch Hand
Posts: 96
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
locate server.xml
in C:\jboss-3.2.3\server\default\deploy\jbossweb-tomcat50.sar folder
change 8080 to 80
<!-- A HTTP/1.1 Connector on port 8080 -->
<Connector port="80" address="${jboss.bind.address}"

Shiang
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic