• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Lomboz not creating XDoclet code

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I've been trying to find a solution for this and have had no luck (why I'm posting my question).

I'm using Eclipse 3 and have recently added in the Lomboz 3 plugin. The problem I'm having, is the Lomboz EJB Wizard is not generating the XDoclet tags when creating new EJBs

Eg: If I create TestSessionBean I get the following code

/**
* @author Owen
*
* TODO To change the template for this generated type comment go to
* Window - Preferences - Java - Code Style - Code Templates
*/
public abstract class TestSessionBean implements SessionBean {

Which is the standard Eclipse comment

Instead I SHOULD be getting this:
/**
* @ejb.bean name="TestSession"
* jndi-name="TestSessionBean"
* type="Stateless"
**/
public abstract class TestSessionBean implements SessionBean {

Something is obviously not configured correctly, but I don't know what. I've tried to disable the auto comment in eclipse, but it doesn't have any effect.

Your help would be greatly appreciated.
-Owen
 
Owen Mead
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I solved this by reinstalling Ecplise and the Lomboz plugins. I'm pretty sure there was a conflict with another plugin or setting somewhere.

If you follow
http://weblogs.asp.net/jdanforth/articles/149111.aspx
to a tee it will probably work for you.

If you are running JBoss you will need to update the server file as described here:
https://coderanch.com/t/89053/JBoss/Unable-Lomboz

jboss4.server (I haven't tested this one)
http://www.talkaboutprogramming.com/group/comp.lang.java.softwaretools/messages/38388.html

Hope this helps someone
 
reply
    Bookmark Topic Watch Topic
  • New Topic