• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Devaka Cooray
  • Ron McLeod
  • paul wheaton
Saloon Keepers:
  • Tim Moores
  • Piet Souris
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Frits Walraven
  • Scott Selikoff

jboss-ide ClassNotFoundException

 
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm trying to start the jboss 4.0 server using the debug feature of jboss-ide. When it starts up, I get a ClassNotFoundException on a utility class that I created that is used by the session ejb. The utility class is part of a jar file called utility.jar. This utility.jar file is contained in the ejb jar file. I can't seem to figure out why I'm getting the error if everything is located in the jar files. I created the utility.jar file using the jboss-ide packaging configuration. I then added the utility.jar to the ejb jar file using the packaging configuration. I was able to get this all to work in a project that had only one .war file and the ejb jar file. Once I added the utility.jar in the same project as the web and ejb code, I'm getting the ClassNotFoundException. Just curious if anyone else has recieved this before.
 
F is for finger. Can you stick your finger in your nose? Doesn't that feel nice? Now try this tiny ad:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic