Win a copy of Head First Android this week in the Android forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Devaka Cooray
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Jj Roberts
  • Al Hobbs
  • Piet Souris

Server Side Includes and jsessionid

 
Ranch Hand
Posts: 81
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi

I am having some trouble with server side includes when the jsessionid is added to the URL - i.e. they are not included at all and I can see the #include statements in the page source.

Once the session cookie has been set and the URL does not have the session id then everything works fine again.

Has anyone else overcome this problem?

Cheers
Steve
 
Sheriff
Posts: 4313
Android IntelliJ IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
that sounds *really* odd. Do you have a very simple JSP page that can reproduce the problem? Also -- what version of JBossAS are you using?
 
Steve McCann
Ranch Hand
Posts: 81
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Jessica

I am using Jboss version 4.0.2.

I did a simple jsp page as you suggested to test with a Struts action that returns to the same page:

The first time I access the page the SSI is at the top as expected. Once I go through the action and the jsessionid is in the URL I don't see the SSI. If I manually remove the jsessionid from the URL it is back again. (I have cookies enabled.)

The only difference is ;jsessionid=A50BC28A812D3F20500898AC44C02ADF is appended to the URL in the second case. Also I am using Apache to process the SSI instead of Tomcat/Jboss.

Thanks
Steve
[ December 07, 2005: Message edited by: Steve McCann ]
 
Jessica Sant
Sheriff
Posts: 4313
Android IntelliJ IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
ooo sorry Steve, I don't have my JBoss instance configured that way, so I can't reproduce the problem... hopefully someone else can help out.

good luck!
 
Steve McCann
Ranch Hand
Posts: 81
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks Jessica.

Out of interest, how do you process your SSI's? I have heard that you can also use Tomcat for this but understood that using Apache in front of Jboss was the 'preferred' method.

Thanks.

Steve
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic