• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Error when starting JBoss - Pls help

 
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I have executed the start method in GlobalStartup MBean in my Jboss management console.Then it gives an exception.Now when Im going to start the server it gives me the following error.

I have removed everything, even the codebase and Jboss and started from the scratch.
Still Im getting the same error.

======================== part of the server lot============
javax.management.InstanceAlreadyExistsException: jboss.management.local:J2EEServer=Local,j2eeType=J2EEApplication,name=print.ear already registered.
at org.jboss.mx.server.registry.BasicMBeanRegistry.add(BasicMBeanRegistry.java:617)
at org.jboss.mx.server.registry.BasicMBeanRegistry.registerMBean(BasicMBeanRegistry.java:198)
at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)

===================================================================

2007-02-09 16:59:41,730 DEBUG [org.jboss.management.j2ee.factory.EARModuleFactory] Created J2EEApplication: jboss.management.local:J2EEServer=Local,j2eeType=J2EEApplication,name=print.ear
2007-02-09 16:59:41,730 INFO [org.jboss.deployment.EARDeployer] Started J2EE application: file:/C:/jboss-3.2.1_tomcat-4.1.24/server/default/deploy/print.ear/
2007-02-09 16:59:41,730 DEBUG [org.jboss.deployment.MainDeployer] End deployment start on package: print.ear
2007-02-09 16:59:41,730 INFO [org.jboss.deployment.MainDeployer] Deployed package: file:/C:/jboss-3.2.1_tomcat-4.1.24/server/default/deploy/print.ear/
2007-02-09 16:59:41,730 DEBUG [org.jboss.deployment.scanner.URLDeploymentScanner] Watch URL for: file:/C:/jboss-3.2.1_tomcat-4.1.24/server/default/deploy/print.ear/ -> file:/C:/jboss-3.2.1_tomcat-4.1.24/server/default/deploy/print.ear/META-INF/application.xml
2007-02-09 16:59:41,730 ERROR [org.jboss.deployment.scanner.URLDeploymentScanner] MBeanException: Exception in MBean operation 'checkIncompleteDeployments()'
Cause: Incomplete Deployment listing:
Packages waiting for a deployer:
<none>
Incompletely deployed packages:
<none>
MBeans waiting for classes:
<none>
MBeans waiting for other MBeans:
[ObjectName: zeborgprint:service=GlobalStartup
state: FAILED
I Depend On: jboss.jca:service=LocalTxCM,name=printPool
jboss.jca:service=ManagedConnectionFactory,name=printPool
jboss.jca:service=ManagedConnectionPool,name=printPool
jboss.j2ee:service=EJB,jndiName=Sequence
jboss.j2ee:service=EJB,jndiName=SequenceMgr

Depends On Me: java.lang.StackOverflowError]

============================================================

Appreiciate any help on this.
Thanks in advance,

jayanath.
 
Ranch Hand
Posts: 982
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
try the temp folders....
 
ranger
Posts: 17347
11
Mac IntelliJ IDE Spring
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I think he meant delete the tmp and work directories and try to restart again.

Mark
 
Jayanath
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi all,
Thanks for your posts..
I found the issue and thought its better to post that for any other readers..
I replaced my db with a new dump and .. thats it.. now its working fine..
I think globleStartup might have corrupted my db

cheers,
Jayanath
reply
    Bookmark Topic Watch Topic
  • New Topic