• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
Sheriffs:
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
Bartenders:
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

localhost and Ip address

 
Ranch Hand
Posts: 94
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I have a question to ask. Thank you in advance.

I started a JBoss (jboss-4.2.0.GA) server in ubuntu linux. It works using

http://localhost:8080/jmx-console

But it does not work in

http://192.168.2.160:8080/jmx-console

Where 192.168.2.160 is IP address of my computer where the server is started.

What's the problem?

By the way, can I remove 8080 by changing something in configuration file?

Regards and thanks,
Forrest
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

I started a JBoss (jboss-4.2.0.GA)



This is the latest version of JBoss and there has been a change to the way JBoss binds its services. The README of this version mentions:

JBossAS now binds its services to localhost (127.0.0.1) *by default*, instead of binding to all available interfaces (0.0.0.0). This was primarily done for security reasons because of concerns of users going to production without having secured their servers properly. To enable remote access by binding JBoss services to a particular interface, simply run jboss with the -b option, but be aware you still need to secure you server properly.



If you want to access the server using the IP address, then you will have to start it as follows:



Ex:



Additionally, if you want the services to be bound like in the previous versions of JBoss, then just start your server using:

 
Forrest Xu
Ranch Hand
Posts: 94
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks, I solved the problem as you mentioned.

another problem is how we can remove 8080 in url?
 
Jaikiran Pai
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Forrest Xu:
another problem is how we can remove 8080 in url?



Hmmm... i havent tried that before, so dont have an answer right now for that.
 
Jaikiran Pai
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Forrest Xu:
another problem is how we can remove 8080 in url?



VirtualHosts might be what you are looking for. Once you configure the virtual hosts, you can access your application with URL like http://www.myapp.com
 
pie. tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic