• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Ant deployment on iAS 6.5

Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi all,
I encountered the following error when I run the ant script on iAS 6.5:
Ant script
<target name="deploy_adaconnectorjar" depends="undeploy_adaconnectorjar">

<echo message="Executing iasdeploy to register ${adaconnectorjar}."/>
<exec dir="${assemble}" executable="${ias.bin}/iasdeploy">
<arg line="deploymodule -verbose ${adaconnectorjar}"/>
D:\AIMS\src\build.xml:1470: Execute failed: java.io.IOException: CreateProcess:
c:\iplanet\ias6\ias\bin\iasdeploy removemodule -verbose cgsAdaConnectorModule.ja
r error=2
java.io.IOException: CreateProcess: c:\iplanet\ias6\ias\bin\iasdeploy removemodu
le -verbose cgsAdaConnectorModule.jar error=2
at java.lang.Win32Process.create(Native Method)
at java.lang.Win32Process.<init>(Win32Process.java:66)
at java.lang.Runtime.execInternal(Native Method)
at java.lang.Runtime.exec(Runtime.java:551)
at java.lang.reflect.Method.invoke(Native Method)
at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Exec
at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:247)
at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:213)
at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:154)
at org.apache.tools.ant.Target.execute(Target.java:142)
at org.apache.tools.ant.Project.runTarget(Project.java:818)
at org.apache.tools.ant.Project.executeTarget(Project.java:532)
at org.apache.tools.ant.Project.executeTargets(Project.java:506)
at org.apache.tools.ant.Main.runBuild(Main.java:420)
at org.apache.tools.ant.Main.main(Main.java:149)
I did not hit this error when I run the script on iAS 6.0. Neither did I encounter any problem when I run the following line command in iAS6.5.

D:\AIMS\src>c:\iplanet\ias6\ias\bin\iasdeploy removemodule -verbose cgsAdaConnec
Would appreciate if you guys could throw some light on overcoming this problems.
Many thanks in advance.
Well THAT's new! Comfort me, reliable tiny ad:
Free, earth friendly heat - from the CodeRanch trailboss
    Bookmark Topic Watch Topic
  • New Topic