• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

How to configure in obj.conf, Failover of cluster in Weblogic

 
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, Please Provide some help....

I got a problem with weblogic proxy with iplanet webserver, when Weblogic is in cluster mode.. The problem is...

I have 2 servers in a cluster., and while one server is processing the request from client., if that server is forcibly shutdown, then the request is going to the second server, and its processing the request perfectly.. Upto now no problem occured., But meanwhile When the first server is up.,
Then i am getting the My screen with 'SessionExpired'.

This also happening in one situation only., which is while the First server is starting, if the second server is under processing requests then
I think first server is not able to synchronize with Second server by retaining session..
But if second server is not processing any requests when the first server startup., No problem occurs..


Presently I am using the obj.conf as below., Please verify the file., and provide if any missing., Please....

--------------------------
<Object name="default">
AuthTrans fn="match-browser" browser="*MSIE*" ssl-unclean-shutdown="true"
NameTrans fn="ntrans-j2ee" name="j2ee"
NameTrans fn=pfx2dir from=/mc-icons dir="/apps/local/iplanet/ns-icons" name="es-internal"
NameTrans fn=document-root root="$docroot"
PathCheck fn=unix-uri-clean
PathCheck fn="check-acl" acl="default"
PathCheck fn=find-pathinfo
PathCheck fn=find-index index-names="index.html,home.html,index.jsp"
ObjectType fn=type-by-extension
ObjectType fn=force-type type=text/plain
Service method=(GET|HEAD) type=magnus-internal/imagemap fn=imagemap
Service method=(GET|HEAD) type=magnus-internal/directory fn=index-common
Service method=(GET|HEAD|POST) type=*~magnus-internal/* fn=send-file
Service method=TRACE fn=service-trace
Error fn="error-j2ee"
AddLog fn=flex-log name="access"
</Object>

<Object name="j2ee">
ObjectType fn=force-type type=text/html
Service fn="service-j2ee" method="*"
</Object>

<Object name="cgi">
ObjectType fn=force-type type=magnus-internal/cgi
Service fn=send-cgi user="$user" group="$group" chroot="$chroot" dir="$dir" nice="$nice"
</Object>

<Object name="es-internal">
PathCheck fn="check-acl" acl="es-internal"
</Object>

<Object name="send-compressed">
PathCheck fn="find-compressed"
</Object>

<Object name="compress-on-demand">
Output fn="insert-filter" filter="http-compression"
</Object>

<Object name="emagia" ppath="*/ee/*">
Service fn=wl_proxy WebLogicCluster="10.2.154.6:7003,10.2.154.6:7005" \
WLIOTimeoutSecs=600
</Object>
-------------------------


Thanx&Regards
Subrahmanyam.O
 
    Bookmark Topic Watch Topic
  • New Topic