Advait Chitalia

Greenhorn
+ Follow
since Mar 24, 2001
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Advait Chitalia

the web.xml file residing under the test\web-inf folder is not readable whereas the web.xml file residing under root\conf folder is readable. Why is it so?
21 years ago
dear Frank,
thanx for your prompt reply at this time of the night there!
i don't know how it happened, but i tried to copy tomcat from a CD . It didn't work. finally, i downloaded the tomcat3.2.1 from the net. Should I copy the web.xml file from the conf directory and paste to the test\WEB-INF directory?
thanx,
-advait.
21 years ago
Hi Frank,
I am actually not able to open the web.xml file. when I try to open it through an editor like Edit Plus, it shows me squares and notext. By the way, i am able to see the contents of the web.xml file located under C:\tomcat\conf\web.xml where c:\tomcat is my TOMCAT_HOME
following is the file content of web.xml located under ..\conf\
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app
PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN"
"http://java.sun.com/j2ee/dtds/web-app_2_2.dtd">
<web-app>
<servlet>
<servlet-name>
default
</servlet-name>
<servlet-class>
org.apache.tomcat.servlets.DefaultServlet
</servlet-class>
<load-on-startup>
-2147483646
</load-on-startup>
........
........
........
<welcome-file-list>
<welcome-file>
index.jsp
</welcome-file>
<welcome-file>
index.html
</welcome-file>
<welcome-file>
index.htm
</welcome-file>
</welcome-file-list>
</web-app>
*************************
thanx,
advait chitalia
[This message has been edited by Advait Chitalia (edited May 17, 2001).]
21 years ago
i am getting the following error in startup.bat window(i have windows NT)-- please help me:
**********************
ERROR reading C:\tomcat\webapps\test\WEB-INF\web.xml
At Document root element is missing.
ERROR reading C:\tomcat\webapps\test\WEB-INF\web.xml
org.xml.sax.SAXParseException: Document root element is missing.
at com.sun.xml.parser.Parser.fatal(Parser.java:2817)
at com.sun.xml.parser.Parser.fatal(Parser.java:2805)
at com.sun.xml.parser.Parser.parseInternal(Parser.java:493)
at com.sun.xml.parser.Parser.parse(Parser.java:284)
at javax.xml.parsers.SAXParser.parse(SAXParser.java:155)
at javax.xml.parsers.SAXParser.parse(SAXParser.java:126)
at org.apache.tomcat.util.xml.XmlMapper.readXml(XmlMapper.java:214)
at org.apache.tomcat.context.WebXmlReader.processWebXmlFile(WebXmlReader
.java:202)
at org.apache.tomcat.context.WebXmlReader.contextInit(WebXmlReader.java:
109)
at org.apache.tomcat.core.ContextManager.initContext(ContextManager.java
, Compiled Code)
at org.apache.tomcat.core.ContextManager.init(ContextManager.java, Compi
led Code)
at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:195)
at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:235)
2001-05-17 02:31:31 - PoolTcpConnector: Starting HttpConnectionHandler on 8080
2001-05-17 02:31:31 - PoolTcpConnector: Starting Ajp12ConnectionHandler on 8007
**********************
-advait chitalia.
21 years ago
Hello guys!
I have a sql query which inserts a record in a table in a MSSQL database. This table has its primary key column as autoincrement. Obviously, I don't mention about the autoincrement column while inserting data. i.e. the 'executeUpdate' query will have all the column names and values except this autoincrement column(in this case the column name is messageID and table name is tDiscussion). This code works perfectly fine at my office. It gives problem when hosted on a different server. At both sides the server running the JSP pages is TOMCAT. I will write my query below and the error under it. Please... help.
QUERY:
String query="INSERT INTO tDiscussion(parent,subject,name,email,date,message,category)"
+"VALUES ('0','"+subject+"','"+name+"','"+email+"','"+datee+"','"+message+"','"+category+"')";

ERROR:
Internal Servlet Error:
javax.servlet.ServletException: [Microsoft][ODBC SQL Server Driver][SQL Server]Cannot insert the value NULL into column 'messageID', table 'photo.photo.tDiscussion'; column does not allow nulls. INSERT fails.
21 years ago
Thank you for the suggestion, but it doesn't work. The errors I get are either classcast exception or internal servlet error. Do you have a clue?
advait.

Originally posted by prabhat kumat:
try to restart the server
if u can pass me the error message ..i cud help u
Prabhat kumar


21 years ago
Hi!
I have my whole JSP site running with Tomcat version 2 in my office on an NT server. The beans are working as well. When I copied the tomcat folder as it is to other place (the webhosting office), the jsp pages are working but not the beans... what could be the problem?
21 years ago
Hi all!
I am finding problems when I try to add a servletbean from the administrative tool of JAVA WEB SERVER 2.0 on WINDOWS NT. It gives me different errors like not able to find the class file/ illegal classFormat/wrong class file name..etc. Basically it is not recognising my bean--i have made a jar file of my class file and stored the jar file under servletbeans directory of java web server root. I also set my classpath to include the servlet.jar file. I am not getting a clue as how do i make any of my beans work on JAva Web Server---any masterminds please?
-thanx, advait.
IP: Logged

All times are MT (US)

21 years ago
Hi all!
I am finding problems when I try to add a servletbean from the administrative tool of JAVA WEB SERVER 2.0 on WINDOWS NT. It gives me different errors like not able to find the class file/ illegal classFormat/wrong class file name..etc. Basically it is not recognising my bean--i have made a jar file of my class file and stored the jar file under servletbeans directory of java web server root. I also set my classpath to include the servlet.jar file. I am not getting a clue as how do i make any of my beans work on JAva Web Server---any masterminds please?
-thanx, advait.
21 years ago
Hello,
can you please help me out? I have hosted my site on Tomcat server on Windows NT and as soon as the tomcat server gets a few error/exception in the JSP files, it gives a java.exe error by Dr.Watson agent and finally I have to shutdown tomcat and start again. I can not afford this as the site dissapears as soon as the tomcat shuts down. Also, it looses the session value, so the user who has logged in has to login allover again. Can you tell me why does this happen? Is tomcat so unstable? I tried to install java Web Server on the server but it doesnot support my 'setAttribute()' and 'getAttribute()' methods. It seems that Java Web Server doesnot get this kind of errors so often and thus the server fellow has to shutdown JWS at the most once in 2-3 months. What should I do, please help.
thanx,
advait.
[This message has been edited by Advait Chitalia (edited March 30, 2001).]
21 years ago
Hi Geniuses,
My JSP site is running on Tomcat server. I am getting the following error when My file tries to connect to the SQL database,
please help.
[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
Thanx, -advait.
21 years ago
Hi!
I am trying to run a JSP site on Java Web Server-- The jsp support is available. But the JSP files which require JDBC connectivity are not running --they give an error as follows:
************
500 Internal Server Error
Java Server Page Translation Error
Error during compilation :
check.java:96: Method setAttribute(java.lang.String, java.lang.String) not found in interface javax.servlet.http.HttpSession.
***********
Also, my beans(java class files) that are stored under 'servlet' directory on the Java Web Server are not working, the beans used to establish a database connection and fetch some data are not able to do so.
21 years ago
Hi!
I am finding problems with running my JSP site hosted on an NT server. The server has Java Web Server running on port 8080 and Tomcat running on 8081. Is it possible to run the two things at the same time? The startup.bat of Tomcat server doesnot get started -the start window either dissapears saying 'path specified not found' or shows some exception and dissapears. What is the solution?
21 years ago