This week's giveaway is in the Java in General forum.
We're giving away four copies of Java Challengers and have Rafael del Nero on-line!
See this thread for details.
Win a copy of Java Challengers this week in the Java in General forum!

Muthuvel Chinnachamy

Ranch Hand
+ Follow
since Jun 13, 2001
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Muthuvel Chinnachamy

Dear All,
We are developing a JSP+Servlets+Applets application. We have developed one version and tested using Internet Explorer 5.0 and it worked fine. But when we tested the same application in netscape 4.7, the application failed to work. Debugged the code and found the problem in the following line.
<form name="entryform" method="post" action="checkentryformservlet"
<a href="javascript:entryform.submit()"><img src="submit.gif"></a>
The Problem is with href statement. I think netscape is not recognising "javascript:entryform.submit()" command.
Is there any way or work around to solve this problem?
Thanks
Muthuvel Chinnachamy
19 years ago
Dear Kyle Brown,
Thanks for your reply.
We are using IBM WAS 3.5 Advanced Edition. I tried with Adminclient <hostname> and it worked well. But in the documentation, it is mentioned that adminclient will not work across firewall. is it correct? And they have mentioned about Web based admin client and I could not find the port number to administer WAS from a browser. Could you please help me to find out the port number?
Also, If I uploaded JSPs and servlets using FTP, Do I have to restart the WAS Application server?
We are using Microsoft FTP Server for ftp services.
Thanks and regards
Muthuvel C.
19 years ago
Dear All,
Is there any tool to administer WAS server remotely. Administration may include uploading Jsp files, servlets and restarting the application server.
Thanks and regards
Muthuvel C.
19 years ago
Dear Rahul,
We are developing a web based application using JSP+servlets and DB2 will be our database. We are using WAS as development server. We develop servlets and JSP pages and publish them to WAS server. After publishing, we have to clear the temp directory and restart the Web application (under default server). This is what we are doing during our development cycle. Sometime back, the java.exe took 99% of CPU time and operation was very slow. I thought restarting the server will help and restarted the server, then problem started. I could not restart the WAS Admin server from menu as well as from control panel, it gives error - service specific error 10.
This is occurring very often and when ever this problem occurs I have to reinstall WAS server again to bring it to normal.
Please help me.
Thanks and regards
Muthuvel C.
19 years ago
Dear Rahul,
Thanks for your reply.
We are using DB2 as database backend.
I have tested the DB2 connectivity with Tomcat server and it is working fine.
Please help me to resolve this problem since it is occurring very often.
Thanks and regards
Muthuvel C.
19 years ago
Dear Rahul,
Again our WAS server Failed to start. The following are the content of the tracefile.
Earlier i had the same problem and I resolved it by reinstalling WAS again.
Please help to solve this problem.
[01.10.16 18:38:07:449 GMT+05:30] 816917c1 AdminServer A Initializing WebSphere Administration server
[01.10.16 18:38:07:559 GMT+05:30] 705697c4 DrAdminServer A DrAdmin available on port 1,093
[01.10.16 18:38:07:889 GMT+05:30] 816917c1 DBMgr F Failed to create a data source: java.sql.SQLException: Problem replaying system journal: java.io.EOFException
at java.sql.SQLException.<init>(SQLException.java:84)
at jdbc.idbConnection.<init>(idbConnection)
at jdbc.idbDriver.connect(idbDriver)
at com.ibm.ejs.cm.pool.JDBC1xConnectionFactory.createConnection(JDBC1xConnectionFactory.java:19)
at com.ibm.ejs.cm.pool.ConnectionPool.createConnection(ConnectionPool.java:635)
at com.ibm.ejs.cm.pool.ConnectionPool.createOrWaitForConnection(ConnectionPool.java:590)
at com.ibm.ejs.cm.pool.ConnectionPool.findFreeConnection(ConnectionPool.java:520)
at com.ibm.ejs.cm.pool.ConnectionPool.findConnectionForTx(ConnectionPool.java:472)
at com.ibm.ejs.cm.pool.ConnectionPool.allocateConnection(ConnectionPool.java:424)
at com.ibm.ejs.cm.pool.ConnectionPool.getConnection(ConnectionPool.java:169)
at com.ibm.ejs.cm.DataSourceImpl.getConnection(DataSourceImpl.java:113)
at com.ibm.ejs.cm.SMDataSource.getConnection(SMDataSource.java:83)
at com.ibm.ejs.sm.util.db.DBMgr.initialize(DBMgr.java:183)
at com.ibm.ejs.sm.server.AdminServer.startConnectionMgr(AdminServer.java:1193)
at com.ibm.ejs.sm.server.AdminServer.initializeRuntime(AdminServer.java:984)
at com.ibm.ejs.sm.server.AdminServer.main(AdminServer.java:353)
FATAL Failed to create a data source: {0} java.sql.SQLException: Problem replaying system journal: java.io.EOFException
at java.sql.SQLException.<init>(SQLException.java:84)
at jdbc.idbConnection.<init>(idbConnection)
at jdbc.idbDriver.connect(idbDriver)
at com.ibm.ejs.cm.pool.JDBC1xConnectionFactory.createConnection(JDBC1xConnectionFactory.java:19)
at com.ibm.ejs.cm.pool.ConnectionPool.createConnection(ConnectionPool.java:635)
at com.ibm.ejs.cm.pool.ConnectionPool.createOrWaitForConnection(ConnectionPool.java:590)
at com.ibm.ejs.cm.pool.ConnectionPool.findFreeConnection(ConnectionPool.java:520)
at com.ibm.ejs.cm.pool.ConnectionPool.findConnectionForTx(ConnectionPool.java:472)
at com.ibm.ejs.cm.pool.ConnectionPool.allocateConnection(ConnectionPool.java:424)
at com.ibm.ejs.cm.pool.ConnectionPool.getConnection(ConnectionPool.java:169)
at com.ibm.ejs.cm.DataSourceImpl.getConnection(DataSourceImpl.java:113)
at com.ibm.ejs.cm.SMDataSource.getConnection(SMDataSource.java:83)
at com.ibm.ejs.sm.util.db.DBMgr.initialize(DBMgr.java:183)
at com.ibm.ejs.sm.server.AdminServer.startConnectionMgr(AdminServer.java:1193)
at com.ibm.ejs.sm.server.AdminServer.initializeRuntime(AdminServer.java:984)
at com.ibm.ejs.sm.server.AdminServer.main(AdminServer.java:353)

Thanks and regards
Muthuvel C.
19 years ago
Dear Rahul,
Please find the trace file content:
Tue Oct 09 16:31:03 2001 - Error - ws_open_domain_client_socket - WaitNamedPipe Tue Oct 09 16:31:03 2001 - Error - ws_open_domain_client_socket - WaitNamedPipe Tue Oct 09 16:31:03 2001 - Error - ws_open_domain_client_socket return error
Tue Oct 09 16:31:03 2001 - Error - ERROR: In do_service_time_request, connect_to_queue failed
Tue Oct 09 16:31:03 2001 - Error - Error passing service/run request ... error 8 on clone 0
Tue Oct 09 16:31:03 2001 - Error - router_service : Failed 8
This I have copied from trace.log.ibmhttp.Tue-Oct-09-15.57.52-2001.
Thanks and regards
Muthuvel C.
19 years ago
Dear All,
I have installed WAS and DB2 and It was working fine. Suddenly, When I rebooted the server and run WAS Administrative console, I get this error "The Admin Client Failed to connect to the Admin Server. Start the local or remote Admin Server service before launching the Admin Client". I have checked the log file adminserver_stderr.log and it shows a long statement which I could not make it.
Also, I have tried to execute the Adminservice from command prompt and getting the following error:
StartServiceCtrlDispatcher failed with error 1063.
Please help me to solve this issue.
Thanks in Advance
Muthuvel C.
[This message has been edited by Muthuvel Chinnachamy (edited October 09, 2001).]
19 years ago
Dear All,
We are using Websphere 3.5 as application server and HTTP server as web server.
I have deployed test version of a jsp file in websphere (under hosts/default_host) and daployed again after making few modifications on the same jsp file. But when we browse thro IE, we found that the old version of JSP file is fetched always.
What could be the problem?
please help
Thanks and regards
Muthuvel C.
19 years ago
Hi all,
We have developed jsp+servlet system and tested under tomcat. It is working fine and we deployed the same application to Websphere and found that it is not working as under tomcat. We done even get error messages and there is no error log generated.
What could be the problem?
please help
Thanks and regards
Muthuvel C.
19 years ago
Dear Theodore,
Thanks for your message and it helped lot. I have added the Internet IP address to the virtual host list and now it is working.
Thanks again.
Muthuvel C.
19 years ago
Dear Peter,
Thanks for your reply.
I will explore more and get you back in case of problem.
Thanks again,
Muthuvel C.
19 years ago
Dear all,
we are developing an internet based application using servlets and beans. At the start of the application, after the user is logged in, the session is started. As part of the application, lots of information is stored in the session for the particular user, (including files uploaded). Now the problem is all these information should be removed from session, files should be deleted at end of the session. Now my question is How do I detect the session end?
Thanks in advance.
Muthuvel Chinnachamy.
19 years ago
Dear All,
My questions are:
1.)Is there any equvalent .xml file in WebSphere like web.xml in Tomcat?

2.) Will WebSphere support Struct?

can anybody help me or send website links for this.
Thanks & Regards
Muthuvel.C
19 years ago
Dear All,
We need to use JSP Taglib in WAS 3.5. JSP 1.1 supports JSP Taglib. How do we enable JSP 1.1 support in WAS 3.5 (it's not showing JSP1.1 enable option) while creating new Application server. Thks in Advance.
urs,
Venkatesh Rajendran
19 years ago