Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!

Deboshree Roy

Greenhorn
+ Follow
since Oct 03, 2007
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Deboshree Roy

Hi,
I know this not the correct forum to post a query related to browser. However, I had had loads of issues solved from here. Please do suggest me any forum for Ie8 if you have come across the following issue.

I am working on XP platform and need to check my application on IE8. I have a functionality of attachment in the application. When the attachment is clicked I want the open/save prompt box to appear.
now the problem is the dialog box is coming in some of the machines with same IE8 and not coming on the others.
I feel the issue is cause someone must have un-checked on the "Always ask before opening" option in the dialog box.
Can someone suggest how to make it re-appear once again after the option has been unchecked.

I have alreay tried the option suggested in the following link:
http://www.winhelponline.com/blog/reset-the-always-ask-before-opening-this-type-of-file-setting/comment-page-2/#comment-11538
My IE8 version is 8.0.6001.18702

Any help is welcome
10 years ago
Hi
I want to introduce a functionality in my application, in which an attachment when clicked on a JSP page should open the Open/save dialog box. and On clicking Open, the pdf should open.
I am writing a servlet for this. The code in the servlet has the following lines:

response.addHeader("Content-disposition","inline; filename="+fileName);
response.setContentType("application/pdf");
response.setContentLength(ret.length);
response.getOutputStream().write(ret);
response.getOutputStream().flush();

Now when I click on the attachment link....It first opens me a bank window then opens the open/save dialog box. On clicking Open I am able to open the pdf file or when I click save I am able to save the document to local system.
However I dont know how to remove the blank window that is opening up when I click on the attachment.

Please advise if anyone has encountered similar scenario. I am using IE6.
10 years ago
HI,

could anyone advise me the changes that would be required if JDK is upgraded from JDK5 to JDK6. My application works on IBM websphere6.1 and WebSphere Application Server6.1. And uses the following technology, JSP, JSR168 Struts portlet, EJB2.1, HIbernate 3.0.
10 years ago
I am getting the exception as shown below while trying to handle transaction handling. I have kept the following jars in the EAR

1) aspectjrt.jar
2) aspectjweaver.jar
3) cglib-2.1.jar

I am getting the exception as shown below while trying to handle transaction handling. I have kept the following jars in the EAR

1) aspectjrt.jar
2) aspectjweaver.jar
3) cglib-2.1.jar

Following is my application-context.xml
<bean id="testBean" class="com.marsh.dRoy.PricingRequest" scope="prototype">
</bean>
<tx:advice id="savePRAdvice" transaction-manager="transactionManager">

<tx:attributes>
<tx:method name="savePricingRequest" propagation="REQUIRED" rollback-for="com.marsh.global.framework.exception.MarshException" />
</tx:attributes>
</tx:advice>
<aop:config>
<aop:pointcut id="createPR" expression="execution(* com.marsh.dRoy.PricingRequest.*(..))"/>
<aop:advisor advice-ref="savePRAdvice" pointcut-ref="createPR"/>
</aop:config>

I am getting the following exception when I try to start my application

[12/29/09 4:44:57:967 EST] 00000017 WebApp SRVE0180I: [NPTWeb] [/NPTWeb] [Servlet.LOG]: Initializing Spring root WebApplicationContext
[12/29/09 4:44:59:171 EST] 00000017 WebApp Unexpected exception parsing XML document from ServletContext resource [/WEB-INF/npt-application-context.xml]; nested exception is java.lang.NoClassDefFoundError: org.aspectj.weaver.BCException
[12/29/09 4:44:59:155 EST] 00000017 SystemErr org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from ServletContext resource [/WEB-INF/application-context.xml]; nested exception is java.lang.NoClassDefFoundError: org.aspectj.weaver.BCException
Caused by: java.lang.NoClassDefFoundError: org.aspectj.weaver.BCException
at java.lang.Class.verifyImpl(Native Method)
at java.lang.Class.verify(Class.java:253)
at java.lang.Class.initialize(Class.java:315)
at java.lang.Class.forNameImpl(Native Method)
at java.lang.Class.forName(Class.java:116)
at org.springframework.aop.config.ConfigBeanDefinitionParser.class$(ConfigBeanDefinitionParser.java:206)
at org.springframework.aop.config.ConfigBeanDefinitionParser.createPointcutDefinition(ConfigBeanDefinitionParser.java:519)
at org.springframework.aop.config.ConfigBeanDefinitionParser.parsePointcut(ConfigBeanDefinitionParser.java:456)
at org.springframework.aop.config.ConfigBeanDefinitionParser.parse(ConfigBeanDefinitionParser.java:140)
at org.springframework.beans.factory.xml.NamespaceHandlerSupport.parse(NamespaceHandlerSupport.java:69)
at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1114)
at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1104)
at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.parseBeanDefinitions(DefaultBeanDefinitionDocumentReader.java:133)
at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.registerBeanDefinitions(DefaultBeanDefinitionDocumentReader.java:90)
at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.registerBeanDefinitions(XmlBeanDefinitionReader.java:458)
at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:353)
at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:303)
at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:280)
at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:131)
at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:147)
at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:124)
at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:92)
at org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:101)
at org.springframework.context.support.AbstractApplicationContext.obtainFreshBeanFactory(AbstractApplicationContext.java:389)
at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:324)
at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:244)
at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:187)
at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:49)
at com.ibm.ws.webcontainer.webapp.WebApp.notifyServletContextCreated(WebApp.java:1355)
at com.ibm.ws.webcontainer.webapp.WebApp.initialize(WebApp.java:371)
at com.ibm.ws.webcontainer.webapp.WebGroup.addWebApplication(WebGroup.java:114)
at com.ibm.ws.webcontainer.VirtualHost.addWebApplication(VirtualHost.java:127)
at com.ibm.ws.webcontainer.WebContainer.addWebApp(WebContainer.java:776)
at com.ibm.ws.webcontainer.WebContainer.addWebApplication(WebContainer.java:729)
at com.ibm.ws.runtime.component.WebContainerImpl.install(WebContainerImpl.java:140)
at com.ibm.ws.runtime.component.WebContainerImpl.start(WebContainerImpl.java:360)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:1019)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.fireDeployedObjectStart(DeployedApplicationImpl.java:1028)
at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:538)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:724)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:683)
at com.ibm.ws.runtime.component.ApplicationMgrImpl$AppInitializer.run(ApplicationMgrImpl.java:1678)
at com.ibm.ws.runtime.component.ComponentImpl$_AsynchInitializer.run(ComponentImpl.java:304)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1332)

[12/29/09 4:44:59:155 EST] 00000017 SystemErr Caused by: java.lang.NoClassDefFoundError: org.aspectj.weaver.BCException
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at java.lang.Class.verifyImpl(Native Method)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at java.lang.Class.verify(Class.java:253)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at java.lang.Class.initialize(Class.java:315)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at java.lang.Class.forNameImpl(Native Method)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at java.lang.Class.forName(Class.java:116)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.aop.config.ConfigBeanDefinitionParser.class$(ConfigBeanDefinitionParser.java:206)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.aop.config.ConfigBeanDefinitionParser.createPointcutDefinition(ConfigBeanDefinitionParser.java:519)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.aop.config.ConfigBeanDefinitionParser.parsePointcut(ConfigBeanDefinitionParser.java:456)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.aop.config.ConfigBeanDefinitionParser.parse(ConfigBeanDefinitionParser.java:140)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.xml.NamespaceHandlerSupport.parse(NamespaceHandlerSupport.java:69)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1114
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1104)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.parseBeanDefinitions(DefaultBeanDefinitionDocumentReader.java:133)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.registerBeanDefinitions(DefaultBeanDefinitionDocumentReader.java:90)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.registerBeanDefinitions(XmlBeanDefinitionReader.java:458)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:353)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:303)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:280)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:131)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:147)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:124)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:92)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:101)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.context.support.AbstractApplicationContext.obtainFreshBeanFactory(AbstractApplicationContext.java:389)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:324)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:244)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:187)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:49)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.webcontainer.webapp.WebApp.notifyServletContextCreated(WebApp.java:1355)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.webcontainer.webapp.WebApp.initialize(WebApp.java:371)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.webcontainer.webapp.WebGroup.addWebApplication(WebGroup.java:114)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.webcontainer.VirtualHost.addWebApplication(VirtualHost.java:127)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.webcontainer.WebContainer.addWebApp(WebContainer.java:776)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.webcontainer.WebContainer.addWebApplication(WebContainer.java:729)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.runtime.component.WebContainerImpl.install(WebContainerImpl.java:140)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.runtime.component.WebContainerImpl.start(WebContainerImpl.java:360)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:1019)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.runtime.component.DeployedApplicationImpl.fireDeployedObjectStart(DeployedApplicationImpl.java:1028)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:538)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:724)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:683)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.runtime.component.ApplicationMgrImpl$AppInitializer.run(ApplicationMgrImpl.java:1678)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr at com.ibm.ws.runtime.component.ComponentImpl$_AsynchInitializer.run(ComponentImpl.java:304)
[12/29/09 4:44:59:171 EST] 00000017 SystemErr
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1332)



10 years ago
Hi,

I have a related problem in my application. I'm implementing the following code in jsp file to display the logged in user id on the top right in the application. But lately I have discovered that it displays the entire loginid inconsistently. Ex. if the login id is Deboshree Roy - LntInfotech, the application displays only Deboshree Roy only.But for id's which I have migrated into the application for them it displays the complete login id (Ex. Jon Tim - British Airways).
This is the code in my JSP file:

<%@ taglib uri="/WEB-INF/tld/portal.tld" prefix="wps" %>
<%@ taglib uri="/WEB-INF/tld/portal-internal.tld" prefix="wps-internal" %>
<%@ include file="../extension/TagLibInclude.jsp" %> <%-- This includes Extend/Express specific tag libraries. --%>
<%@page import="java.util.StringTokenizer"%>
<%@page import="com.ibm.portal.portlet.service.PortletServiceHome"%>
<%@page import="com.ibm.portal.puma.User"%>
<%@page import="com.ibm.portal.um.PumaHome"%>
<%@page import="com.ibm.portal.um.PumaProfile"%>

<wps-internal:adminNavHelper/>
<wps:constants/>
<wps:defineObjects/>
<html>

<%@ include file="./Head.jsp" %>
<%
String user_objid = "";
String strUser = null;
com.ibm.portal.puma.User portalUser= (com.ibm.portal.puma.User)request.getAttribute(com.ibm.portal.RequestConstants.REQUEST_USER_OBJECT);
if (portalUser != null) {
strUser=portalUser.getFullName();
}
%>

If anyone has successfully displayed loginid in a JSr 168 application on Portal 6.1 please do let me know.The application is integrated with LDAP to obtain the login details.
11 years ago
I'm Migrating my application built on Portal(JSR-168) 5.1 and WAS 5.1 environment to Portal and WAS 6.1 environment on RA 7.5.

In some of the modules I'm facing issues when I try to pass data from JSP page to Action class setting the value on session object.

In one of the Module:

The records are visible from database,however , the application throws a Null Pointer exception when any record on the page for view.
id of the record set in jsp page is not being retrieved in the Action class. Please find below the code extract on the jsp page and the corresponding action it is being forwarded to.

In JSP:
<html:link action="/ACViewCertificateAction.do" paramName="innerCertAddenList" paramId="CERT_ID"paramProperty="certificateId">
<bean:write name="innerCertAddenList" property="clientName" />
</html:link>

In Action:
certificateID = request.getParameter(ACCommonConstantsIF.AC_CERTIFICATE_ID);(PortletRequest request,public static final String AC_CERTIFICATE_ID = "CERT_ID";)


In User Administration:

The List of records fetched into the Action class,set in the PortletSession is not being recognized in the forwarded JSP page:

In ACUserListAction:
fullList = getLDAPList();
System.out.println("*******fullList in User List Action*******"+fullList.size());//Size is 1490
request.getPortletSession().setAttribute(
ACCommonConstantsIF.LDAP_FULL_LIST, fullList);
servletRequest.getSession().setAttribute(
ACCommonConstantsIF.LDAP_FULL_LIST, fullList);
Collections.sort(fullList, comparator);
acUserForm.setAcOrganisationList(organisationList);
acUserForm.setAcLdapUsersList(fullList);
request.getPortletSession().setAttribute(
ACCommonConstantsIF.LDAP_USERS_LIST, fullList);
marshUsers = (ArrayList) ACCommonUtil.doPaging(request,
selectedPage, fullList,
ACCommonConstantsIF.VIEW_LIST_PAGEITERATOR);
request.getPortletSession().setAttribute(
ACCommonConstantsIF.LDAP_SELECTED_USERS_LIST, marshUsers);
servletRequest.getSession().setAttribute(
ACCommonConstantsIF.LDAP_SELECTED_USERS_LIST, marshUsers);

In ACUserViewByName.jsp:
<table class="portlet-menu">
<TBODY>
<logic:notEmpty name="LDAPSelectedUsersList" scope="session">
<tr class="wpsTableHead">
<td class="wpsTableSectionHead"><bean:message
key="User.LoginName.List" /></td>
<td class="wpsTableSectionHead"><bean:message
key="User.Name.List" /></td>
<td class="wpsTableSectionHead"><bean:message
key="User.Company.List" /></td>
<td class="wpsTableSectionHead"><bean:message
key="User.EmailAddress.List" /></td>
</tr>
<logic:iterate name="LDAPSelectedUsersList" id="userList1"
type=" com.marsh.ac.dvo.ACUserDVO" scope="session">
<%com.marsh.ac.dvo.ACUserDVO userDVO = null;
if (userList1 instanceof com.marsh.ac.dvo.ACUserDVO) {
userDVO = (com.marsh.ac.dvo.ACUserDVO) userList1;
%>
<tr class="wpsTableRow">
<TD class="wpsTableHeadLink" <br /> >
<bean:write name="userList1" property="loginName" />
</td>
<td class="portlet-menu"><bean:write name="userList1"
property="firstName" /> <bean:write name="userList1"
property="lastName" /></td>
<td class="portlet-menu"><logic:notEmpty name="userList1"
property="company">
<bean:write name="userList1" property="company" />
</logic:notEmpty>
<logic:empty name="userList1"
property="company"> </logic:empty></td>
<td class="portlet-menu"><bean:write name="userList1"
property="emailAddress" /></td>
</tr>
<%
}
%>
</logic:iterate>
</logic:notEmpty>

<logic:empty name="LDAPSelectedUsersList" scope="session">
<tr>
<td class="wpsPortletHead"><bean:message key="User.RecordsNotFound" /></td>
</tr>
</logic:empty>


(Currently control in returning to the JSP without any list of records).

If anybody has faced such issue in MIgration can you please help.
11 years ago
Hi!

I am trying to look up another application(say A) from the EJB code of my application(say B) by exposing the API of that application in my application.
This was working fine in 5.1 environment. Bur faltering on 6.1.
The EJB version in my application is 2.1 on both the applications now.This is code which is used in my servicelocator to look up application A:

props = readerUtil.getProperyByName(ACBusinessConstantsIF.EJB_CONFIG_FILE_NAME);
if(null != props)
{
Context ctx = new InitialContext();
String providerURL= (String)ctx.lookup("AC_GRP_EJB_JNDI");
aProperties.put(ACBusinessConstantsIF.CONTEXT_FACTORY_NAME,props.getProperty("grp.java.naming.factory.initial"));
Properties.put(ACBusinessConstantsIF.PROVIDER_URL,providerURL);
jndiName = props.getProperty(ACBusinessConstantsIF.GRP_JNDI_NAME);
}else{
aProperties = getContextProperties("AC_GRP_EJB_JNDI");
jndiName = aProperties.getProperty(ACBusinessConstantsIF.GRP_JNDI_NAME);
}



String factoryClassName = ACBusinessConstantsIF.FACTORY_NAME;
if (null == factoryClassName) {
} else {
try{
System.out.println("********null != props*******9****");
Object obj = (((ACServiceLocator) Class.forName(factoryClassName)
.newInstance()).initialize(aProperties, jndiName)).create();
System.out.println("********null != props******10*****");
GroupManagementHome groupMgmtHome = (GroupManagementHome) PortableRemoteObject
.narrow(obj, GroupManagementHome.class);
System.out.println("********null != props******11*****");
services = (GroupManagement) groupMgmtHome.create();
System.out.println("********null != props******12*****");
}catch(Exception ex){
System.out.println("*********In catch of ServcieLocator*****"+ex);
ACFatalException fatalException = new ACFatalException();
ACMessage message = new ACMessage();
message.setCode(ACBusinessConstantsIF.GRP_SERVICE_ERROR);
message.setDescription(ACBusinessConstantsIF.GRP_SERVICE_ERROR);
fatalException.addMessage(message);
throw fatalException;
}

The application is faltering at the GroupManagementHome lookup(after the sysout 9).
This is the error that I have located in the logs:

javax.naming.NameNotFoundException: Context: ukdev3ptlshe/clusters/WPTL, name: ejb/com/marsh/groupmanagement/services/GroupManagementSOAPImpl: First component in name marsh/groupmanagement/services/GroupManagementSOAPImpl not found. [Root exception is org.omg.CosNaming.NamingContextPackage.NotFound: IDL:omg.org/CosNaming/NamingContext/NotFound:1.0]


Could Anybody suggest what could be the probable issue for this error.
11 years ago
Hi,
I have used two customised tld in my Portal application(JSR-168) and I need to migrate y application from Websphere Portal5.1 env to websphere Portal env-6.1.the entry in mentioned in my web.xml. Yet when deployed, it gives the following error:
com.ibm.ws.jsp.taglib.TldParser logParseErrorMessage Failed to parse Tag Library [/WEB-INF/PageNavigator.tld]: JSPG0036E: Failed to find resource file:/D:/Apps/Wptl/ukdev3ptlshe/PtlSrv01/installedApps/ukdev3ptlshe/PA_AviationCertWeb.ear/AviationCert.war/WEB-INF/PageNavigator.tld
[1/15/09 12:08:04:456 GMT] 00000021 jsp W com.ibm.ws.jsp.taglib.TagLibraryCache loadWebXmlMap jsp warning failed to load tld at [/WEB-INF/PageNavigator.tld]
[1/15/09 12:08:04:471 GMT] 00000021 jsp W com.ibm.ws.jsp.taglib.TagLibraryCache loadWebXmlMap jsp warning failed to load tld at [/WEB-INF/PageNavigator.tld]
[1/15/09 12:08:04:471 GMT] 00000021 jsp E com.ibm.ws.jsp.taglib.TldParser logParseErrorMessage Failed to parse Tag Library [/WEB-INF/menuTag.tld]: JSPG0036E: Failed to find resource file:/D:/Apps/Wptl/ukdev3ptlshe/PtlSrv01/installedApps/ukdev3ptlshe/PA_AviationCertWeb.ear/AviationCert.war/WEB-INF/menuTag.tld
[1/15/09 12:08:04:471 GMT] 00000021 jsp W com.ibm.ws.jsp.taglib.TagLibraryCache loadWebXmlMap jsp warning failed to load tld at [/WEB-INF/menuTag.tld]

Menu Tag.tld

<!DOCTYPE taglib
PUBLIC "-//Sun Microsystems, Inc.//DTD JSP Tag Library 1.2//EN"
"http://java.sun.com/dtd/web-jsptaglibrary_1_2.dtd">;

<!-- a tab library descriptor -->
<taglib xmlns="http://java.sun.com/JSP/TagLibraryDescriptor">;
<tlib-version>1.0</tlib-version>
<jsp-version>1.2</jsp-version>
<short-name>Menu Tag</short-name>

<!-- this tag lists random numbers; the HTML is hard-coded within
the tag handler
-->
<tag>
<name>menuTag</name>
<tag-class>com.marsh.ac.web.taglib.ACMenuTag</tag-class>
<body-content>JSP</body-content>
<attribute>
<name>choice</name>
<rtexprvalue>true</rtexprvalue>
</attribute>
<attribute>
<name>dropOption</name>
<rtexprvalue>true</rtexprvalue>
</attribute>
<attribute>
<name>dropdown</name>
<required>true</required>
<rtexprvalue>true</rtexprvalue>
</attribute>
<attribute>
<name>selectid</name>
<rtexprvalue>false</rtexprvalue>
</attribute>
<attribute>
<name>url</name>
<rtexprvalue>true</rtexprvalue>
</attribute>
</tag>
</taglib>

[1/15/09 12:08:04:471 GMT] 00000021 jsp W com.ibm.ws.jsp.taglib.TagLibraryCache loadWebXmlMap jsp warning failed to load tld at [/WEB-INF/menuTag.tld]

Page Navigator.tld:
<!DOCTYPE taglib
PUBLIC "-//Sun Microsystems, Inc.//DTD JSP Tag Library 1.2//EN"
"http://java.sun.com/dtd/web-jsptaglibrary_1_2.dtd">;

<!-- a tab library descriptor -->
<taglib xmlns="http://java.sun.com/JSP/TagLibraryDescriptor">;
<tlib-version>1.0</tlib-version>
<jsp-version>1.2</jsp-version>
<short-name>Java2s Simple Tags</short-name>


<!-- this tag iterates over its body a number of times -->
<tag>
<name>pageNavigator</name>
<tag-class>com.marsh.ac.web.taglib.ACPageNavigatorTag</tag-class>
<body-content>JSP</body-content>
<attribute>
<name>index</name>
<rtexprvalue>true</rtexprvalue>
</attribute>
<attribute>
<name>itemsPerPage</name>
<rtexprvalue>true</rtexprvalue>
</attribute>
<attribute>
<name>page</name>
<rtexprvalue>true</rtexprvalue>
</attribute>
<attribute>
<name>itemsListSize</name>
<rtexprvalue>true</rtexprvalue>
</attribute>


</tag>

</taglib>

Can anybody through some light on this issue.
11 years ago
HI,

I am enountering the following error after migrating my application from Portal 5.1 to Portal6.1 environment.
com.ibm.ws.jsp.taglib.TagLibraryCache loadTaglibTldFromJar jsp error failed to parse tld in jar. uri = [/WEB-INF/lib/utility.jar]
com.ibm.ws.jsp.JspCoreException: JSPG0234E: The JSP container is unable to locate the Java archive (JAR) resource [/WEB-INF/lib/utility.jar] to parse tag library descriptors (TLDs).
at com.ibm.ws.jsp.taglib.TagLibraryCache.loadTaglibTldFromJar(TagLibraryCache.java:449)
at com.ibm.ws.jsp.taglib.TagLibraryCache.loadWebXmlMap(TagLibraryCache.java:149)
at com.ibm.ws.jsp.taglib.TagLibraryCache.<init>(TagLibraryCache.java:99)
at com.ibm.ws.jsp.webcontainerext.AbstractJSPExtensionProcessor.<init>(AbstractJSPExtensionProcessor.java:166)
at com.ibm.ws.jsp.webcontainerext.ws.WASJSPExtensionProcessor.<init>(WASJSPExtensionProcessor.java:65)
at com.ibm.ws.jsp.webcontainerext.ws.WASJSPExtensionFactory.createProcessor(WASJSPExtensionFactory.java:188)
at com.ibm.ws.jsp.webcontainerext.AbstractJSPExtensionFactory.createExtensionProcessor(AbstractJSPExtensionFactory.java:75)
at com.ibm.ws.webcontainer.webapp.WebApp.initializeExtensionProcessors(WebApp.java:1124)
at com.ibm.ws.webcontainer.webapp.WebApp.commonInitializationFinish(WebApp.java:304)
at com.ibm.ws.wswebcontainer.webapp.WebApp.initialize(WebApp.java:290)
at com.ibm.ws.wswebcontainer.webapp.WebGroup.addWebApplication(WebGroup.java:92)
at com.ibm.ws.wswebcontainer.VirtualHost.addWebApplication(VirtualHost.java:157)
at com.ibm.ws.wswebcontainer.WebContainer.addWebApp(WebContainer.java:665)
at com.ibm.ws.wswebcontainer.WebContainer.addWebApplication(WebContainer.java:618)
at com.ibm.ws.webcontainer.component.WebContainerImpl.install(WebContainerImpl.java:335)
at com.ibm.ws.webcontainer.component.WebContainerImpl.start(WebContainerImpl.java:551)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:1303)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.fireDeployedObjectStart(DeployedApplicationImpl.java:1138)
at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:569)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:817)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:949)
at com.ibm.ws.runtime.component.ApplicationMgrImpl$AppInitializer.run(ApplicationMgrImpl.java:2122)
at com.ibm.wsspi.runtime.component.WsComponentImpl$_AsynchInitializer.run(WsComponentImpl.java:342)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1473)

I have made the chages in the application wrt to struts tld as intructed in the Migration guide, i.e removed the following tld's from the wEB-INF folder and replaced the taglib URI entry in the JSP page with the required url:
 struts-bean.tld
 struts-chtml.tld
 struts-html.tld
 struts-logic.tld
 struts-nested.tld
 struts-portal-html.tld
 struts-portal-wml.tld
 struts-template.tld
 struts-tiles.tld
 struts-wml.tld

 http://struts.apache.org/tags-bean
 http://struts.apache.org/tags-chtml
 http://struts.apache.org/tags-html
 http://struts.apache.org/tags-logic
 http://struts.apache.org/tags-nested
 http://portal/struts/tags-html-1.0
 http://portal/struts/tags-wml-1.0
 http://struts.apache.org/tags-template
 http://struts.apache.org/tags-tiles
 http://struts.apache.org/tags-wml-1.0

And I have removed the entry of these tld's from my web.xml.
But the Utility jar for which the error is encountred is there in the WEB-INF. Please guide if anybody has encounterd the similar error and solved successfully.
11 years ago
Hi,
Its the again more issues with migration from Portal 5.1 to Portal 6.1
On deploying the war and ear modules in my project(The war and ear are packaged separately on portal (Websphere Portal 6.1)and application server(Websphere Application Server 6.1) respectively).
The Portla pages in the application are not visibile after I login. The error on the page is "This portlet is temporarily disabled"
Please find attached the error seen in the logs.
Does anybody has any idea what needs to be done?
11 years ago
Hi
I have made a full installation of Webspere Portal Server(WPS)6.1 on my system.
ejb2.0 was the version that was working on my portal 5.1. But I have migrated on RAD 7.5 using the Migration Wizard to ejb2.1.
The error is coming while executing the wsejbdeploy task.It is not able to lookup the AppServer path (I guess),But when I echo the WASHome path in the script it is displaying the correct path.
11 years ago
Hi,
I provide the path for the build.xml and key in the ant command to start the build process.That is how it was done when my code was originally on WAS and WPS 5.1 and I'm following the same procedure on migration to WAS and WPS 6.1
11 years ago
Hi,

I'm using apache-ant-1.6.1 for building my code.
11 years ago
Hi,
I am trying to build my ejb module useing ANT 1.6.1 on WAS6.1.
I'm getting the following error:
Unable to parse setupCmdLine: null\bin\setupCmdLine.bat (The system cannot find the path specified.)
at com.ibm.ws.ant.utils.ProjectUtils.reportError(ProjectUtils.java:30)
at com.ibm.ws.ant.utils.WasUtils.parseScriptFile(WasUtils.java:257)
at com.ibm.ws.ant.utils.WasUtils.parseProfileScriptFile(WasUtils.java:13
6)
at com.ibm.ws.ant.utils.WasUtils.parseSetupCmdLine(WasUtils.java:115)
at com.ibm.websphere.ant.tasks.WsEjbDeploy.execute(WsEjbDeploy.java:519)

at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:269)
at org.apache.tools.ant.Task.perform(Task.java:364)
at org.apache.tools.ant.Target.execute(Target.java:301)
at org.apache.tools.ant.Target.performTasks(Target.java:328)
at org.apache.tools.ant.Project.executeTarget(Project.java:1215)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:383)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:269)
at org.apache.tools.ant.Task.perform(Task.java:364)
at org.apache.tools.ant.Target.execute(Target.java:301)
at org.apache.tools.ant.Target.performTasks(Target.java:328)
at org.apache.tools.ant.Project.executeTarget(Project.java:1215)
at org.apache.tools.ant.Project.executeTargets(Project.java:1063)
at org.apache.tools.ant.Main.runBuild(Main.java:632)
at org.apache.tools.ant.Main.startAnt(Main.java:183)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:197)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:56)

I saw a few links on this particular error, but couldnt find any proper solution.
Please do let me know if anyone came across this issue and solved it successfully.
11 years ago
Hi,
I have migrated my project code on WAS and WPS 6.1.I run a ANT script to build the codebase.
In the EJB module when I build the code using ANT(1.6.1), I am getting the following error:
BUILD FAILED
Could not create type wsejbdeploy due to java.lang.NoClassDefFoundError: com.ibm.ws.ant.utils.WasUtils

I have included the websphere_apis.jar(Which contains ths WsEjbDeploy class) in the shared library and also in the library file of the ejb module.

any help would be great help.
Thanks in advance.
11 years ago