shajid basha

Greenhorn
+ Follow
since Jun 13, 2009
Merit badge: grant badges
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by shajid basha

Hi Peer,

Please can you help me on the below link topic:

https://coderanch.com/t/449487/Web-Services/java/org-xml-sax-SAXException-Invalid

Thanks,
Shajid
13 years ago
Hi Bill,

But if i deploy only this webservice then its working fine. When i deploy with the second service, then only i am getting this problem...

Is their any problem with the namespaces....

I am very thankful to you for your precious time.

Thanks,
Shajid
13 years ago
Bill,

But, they all are have similar packages...
13 years ago
Hi Bill,

No all 3 are different services....

Shajid
13 years ago
Hi Bill,

Q) What about the stack trace?

org.xml.sax.SAXException: Invalid element in BeanService.OutletStatus - allItemsAvailable
at org.apache.axis.encoding.ser.BeanDeserializer.onStartChild(BeanDeserializer.java:258)
at org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1035)
at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165)
at org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141)
at org.apache.axis.encoding.DeserializerImpl.startElement(DeserializerImpl.java:369)
at org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1048)
at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165)
at org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141)
at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:236)
at org.apache.axis.message.RPCElement.getParams(RPCElement.java:384)
at org.apache.axis.client.Call.invoke(Call.java:2467)
at org.apache.axis.client.Call.invoke(Call.java:2366)
at org.apache.axis.client.Call.invoke(Call.java:1812)
at _20._2._1._10.axis.services.ProductLocator.ProductLocatorSoapBindingStub.filteredDivisionFind(ProductLocatorSoapBindingStub.java:308)
at com.ebiz.es.ProductLocatorProcessor.COS_543_ProductLocatorProcessorSOAP_V10Impl.COS_543_performProductLocatorProcessorServices_V10(COS_543_ProductLocatorProcessorSOAP_V10Impl.java:64)
at com.ebiz.es.ProductLocatorProcessor.COS_543_ProductLocatorProcessorSOAP_V10Skeleton.COS_543_performProductLocatorProcessorServices_V10(COS_543_ProductLocatorProcessorSOAP_V10Skeleton.java:56)

Q) What resources are these apps sharing?

This services invokes one more service and get the response. Thats it. It wont include any other resources.

Q) When Tomcat throws that exception, what do you see on the client side?

It throws the same exception what is in Q 1. and at client side i can see only empty body tags in SoapUI.

Q) Do all subsequent requests throw the same exception?

Yes, all the subsequent requests from this service throws same exception.



Please let me know if any of my answers are not understand for you.


Thanks,
Shajid Basha

13 years ago
Hi Bill,

Thanks for your reply. I am getting that error at the time of submitting the request, not at the time of Tomcat start.

In my tomcat first 2 webservices are working fine (if i dont place the 3rd one). But When i place the third one then the 2nd service is getting that error. But the 1st and 3rd is working fine.

Thanks,
Shajid Basha.
13 years ago
Hi Bill,

I want to add one more point. If i deploy only this(current service which i am talking about) service then i wont get any problem. When i deploy with the service which are already present then i am getting this error.

Thanks,
Shajid Basha
13 years ago
Hi Bill,

I have used SoapUI only. But, i dint find any error from that tool. Only empty body tags i am getting. I am able to see this "org.xml.sax.SAXException: Invalid element" in tomcat.

Can you guide me please.

Thanks,
Shajid Basha
13 years ago
Hi,

Any one can help on this please....
If you need any more information, please let us know.

Thanks,
Shajid Basha
13 years ago
Hi,

Using Axis1.4

I have 2 webservices already in my tomcat server. Both are working fine. When i deploy 3rd service then i am facing the below error. But if i place this 3 rd service Only then its working fine. Please can any one guide me what the problem is and where?

Error: org.xml.sax.SAXException: Invalid element in BeanService.OutletStatus - allItemsAvailable


Thanks in Advance.
Shajid
13 years ago