Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!

Dolfino Proteus

Greenhorn
+ Follow
since Jan 12, 2010
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Dolfino Proteus

Blame on me...

I'm developing on Eclipse and I switched off the auto-build feature... obviously every change I made was ignored by the application server that was deploying every time the same sources

Have a nice day all!
Dolfiz
10 years ago
Hi all!

I'm making some changes to a web application that uses an ApplicationResources.properties file and "<bean:message ..." tag to take labels from it.
I only need to add a label on a jsp page where other labels are used.

I added a key-value pair in the .properties file:

The second line is mine, the first one was there before.
And then I used, of course, the struts tag:

If I use only the first one, it works fine, but when I add my label, it causes a "Missing message for key" error.

I really don't understand. Same .properties file, same syntax and I'm sure that I wrote the keys consinstently... where am I falling?!

Thank you all.
Dolfiz
10 years ago
Hi all!

First post on JavaRanch
(but I know and use this site since I've started to program)

Here's the problem...

I've got an iterate tag as:

inside the iterate block there is a link associated with a javascript function, passing some bean property as parameter of the function like:

It is all working correctly, but if the name property (a string object from the server-side) contains an apex (a single quote like ' ) then a js-error occurs. I can understand easily why this happens (after all is a simple syntax error) but I can't figure out how to solve the problem Does someone know a good way?

Thank you all in advance,
Dolfino
10 years ago