Win a copy of Rust Web Development this week in the Other Languages forum!

RajHans Kumar

Greenhorn
+ Follow
since Apr 20, 2011
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
1
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by RajHans Kumar

Hello

I have been trying to connect AF from a Wps application .
I have put all the requisite jars on the classpath and have restarted the application as well .
However , I am getting the following error :
ibm.ws.webcontainer.servlet.ServletWrapper service SRVE0068E: Uncaught exception created in one of the service methods of the servlet login in application wps. Exception created : java.lang.NoClassDefFoundError: org.slf4j.LoggerFactory
at com.aviva.nui.af.bridging.SocketProxy.<clinit>(SocketProxy.java:25)

The problem with giving exact classpaths is that while Wps Application tries to get connectivity to AF, it refers to a loggerFactory class available under slf4j-log4j12-1.5.6.jar present under the set of jars specified in AF folder structure.But seems that the classpath is not getting picked up as expected by wps application leading to above errors.

Can anyone help - urgent ?

Regards
Raj
10 years ago
Is there a site where I can get a sspi(CVS) plugin for eclipse ?
I have tried googling a lot but wasn't able to find any .
Could someone please help ?



Regards
RajHans
Can anyone help me in creating a Project Set in Eclipse ?
I have a requirement of making a .psf file (team project set) but before that I need to export the different Projects into a Project Set ?



Thanks in advance
RajHans
Hi All


I have a plugin.class in which I am calling methods in another classes.
The other classes need some jars which have added up in the classpath .
Now the problem is whenever I am trying to deploy a plugin in the same instance of eclipse by doing
an File ->Export ->Plug-in Development ->Deployable plug-ins and fragments
And selecting that package I am getting an error which are of type :

" ERROR in D:\WorkSpace\com.example.helloworld\src\com\example\helloworld\view\Check.java (at line 4)
import org.apache.poi.xssf.usermodel.XSSFSheet;
^^^^^^^^^^
The import org.apache cannot be resolved"
(These errors aren't displayed in the normal editor)

1.Do I need to add all these poi-jars somewhere ?(have already added them in the Build tab of the plugin.xml)
2.Is there anyother way to remove these errors and get the plugin deplyed

Kindly advise .

Thanks
Hi Sourav

Was able to run the plugin in the same instance of Eclipse so was successful in doing that.

However ,of-late I have a different problem. I tried changing the code in the class given in the Extensions and tried redeploying the plugin .
But ,I am getting an error as
"An error has occurred when activating this view
java.lang.NullPointerException"

I have tried cleaning my eclipse and also using a differnt workspace ,but still the same error persists even if I try using a different instance of eclipse to run the plugin.

Could you tell me what the problem might be ?

Regards
Thanks mate
I tried making a Jar out of the plugin and keeping it in the Plugin folder of the eclipse installed directory .However I am getting an error now
"Could not create the view: Plug-in com.example.helloworld was unable to load class com.example.helloworld.views.com."
Hi Sourav

Thanks got my problem fixed
One last question though
Can I run a plugin from the same instance of the Eclipse ?

Regards
Hi

I have also created the class now ,however I am getting an exception on clicking the Hello World button as in the Window-Show-Other menu .

"Could not create the view: com.example.helloworld.view.SampleView cannot be cast to org.eclipse.ui.IViewPart"


Could anyone let me know how to resolve this ?

Thanks
Hey Sourav

Thanks a lot mate
That worked and I was able to create a simple plugin using the cheatcodes

However,when I tried creating a plug-in extension I faced quite a few problems :
As in the cheatcode:-
"To create a view class, perform the following steps:
Click the "class" hyperlink under "Extension Element Details" to start the "New Java Class" wizard
Accept the default values and click the "Finish" button to exit the wizard "

Now the view and category for the org.eclipse.ui.views weren't coming by default so I changed the plugin.xml as
<extension
id="com.example.helloworld.view.helloworldcategory"
name="Hello World!"
point="org.eclipse.ui.views">
<category
id="com.example.helloworld.view.helloworldcategory"
name="Hello World!">
</category>
<view
id="com.example.helloworld.view.helloworld"
name="Hello World!"
icon="icons/view16/sections.png"
category="com.example.helloworld.view.helloworldcategory"
class="com.example.helloworld.view.SampleView">
</view>
</extension>

However,wasn't getting a hyperlink for the class as in:
"To create a view class, perform the following steps:
Click the "class" hyperlink under "Extension Element Details" to start the "New Java Class" wizard
Accept the default values and click the "Finish" button to exit the wizard "

My eclipse version is 3.5.0


Thanks in advance


Hi Sourav

Thanks for the quick reply .
I have made a Plug -in project which has manifest.mf file
The contents of which are as below:

Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Helloworld
Bundle-SymbolicName: org.eclipse.examples.helloworld;singleton:=true
Bundle-Version: 1.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.6


The plugin.xml has some warnings though ,don't know again if thats the cause:

<?xml version="1.0"?>
<plugin
name="Eclipse Hello World Example"
id="org.eclipse.examples.helloworld"
version="0.0.0"
provider-name="OTI">

<requires>
<import plugin="org.eclipse.core.resources"/>
<import plugin="org.eclipse.ui"/>
</requires>

<runtime>
<library name="helloworld.jar"/>
</runtime>

<extension point = "org.eclipse.ui.actionSets">
<actionSet
id="org.eclipse.examples.helloworld.HelloWorldActionSet"
label="Hello World"
visible="true"
description="The action set for the Eclipse Hello World example">
<menu
id="org.eclipse.examples.helloworld.HelloWorldMenu"
label="Samples">
<separator name="samples"/>
</menu>
<action id="org.eclipse.examples.helloworld.actions.HelloWorldAction"
menubarPath="org.eclipse.examples.helloworld.HelloWorldMenu/samples"
toolbarPath="Normal"
label="Hello World"
tooltip="Press to see a message"
icon="icons/helloworld.gif"
class="org.eclipse.examples.helloworld.HelloWorldAction"/>
</actionSet>
</extension>
</plugin>

I am still getting the same exceptions

Is there something wrong in the above two files ??

Hi Sourav

I have a Project named org.eclipse.examples.helloworld inside which I have the src folder and inside that I have the package org.eclipse.examples.helloworld.The Java class HelloWorldAction is inside this package.
Now I dont know how to "Run->Run As->Run-time Workbench " as in the article.
I have tried running the entire package as Run Configuration but I am getting an error

"java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:556)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)"

Could you let me know
1.How do I run the WorkBench ?
2.How to deal with this exception ?

Thanks

Hi

I am trying to create a Plugin in eclipse but have been struggling .
The main purpose is to call some functions from some classes using the plugin.
I have been following the below link:
http://www.eclipse.org/articles/viewArticle/ViewArticle2.html
However,wasn't succesful.

Thanks in advance
Any idea about this exception ?
Thanks a lot
That was silly
Now I have updated as per the comments and my classpath is
D:\toold\poi-jars\dom4j-1.6.1.jar;D:\toold\poi-jars\geronimo-stax-api_1.0_spec-1.0.jar;D:\toold\poi-jars\xmlbeans-2.3.0.jar;D:\toold\poi-jars\poi-ooxml-3.7-20101029.jar;D:\toold\poi-jars\poi-ooxml-schemas-3.7-20101029.jar;D:\toold\poi-jars\poi-scratchpad-3.7-20101029.jar;D:\toold\poi-jars\poi-3.7-20101029.jar;D:\toold\poi-jars\poi-examples-3.7-20101029.jar

I am still getting an exception
org.apache.poi.POIXMLException: org.apache.poi.openxml4j.exceptions.InvalidFormatException: Package should contain a content type part [M1.13]
at org.apache.poi.util.PackageHelper.open(PackageHelper.java:41)
at org.apache.poi.xssf.usermodel.XSSFWorkbook.<init>(XSSFWorkbook.java:186)
Is there anyother Jar needed ?
Is the classpath correct ?