Nelo Angelo

Ranch Hand
+ Follow
since Jul 25, 2011
Nelo likes ...
Eclipse IDE Chrome Java
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
2
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Nelo Angelo

Hello everyone,

I tried to search this topic on the internet but couldn't get any proper solution. I want to open a page through my Servlet and capture response that is received from the server so that I could alter/retrieve the data I get from the response. I am not talking about filtering the data sent from my own servlet but getting the response from other websites.

Any suggested reading would be greatly appreciated.

Basically, I was trying to extract all the hrefs present on a page through FileIO. But that can be tedious process as I had to download the pages before-hand. Is there any other way to do this? Please advice.
9 years ago
Hey everyone,

This seems like a very stupid question but I kinda searched all over the internet for a valid example containing @WebParam and I could not get any decent example that used input and output to show how the @WebParam annotation actually works.

It would be greatly appreciated if someone could give an example of a @WebParam usage or point me to a URL that shows its working.
9 years ago
Hello everyone,

I am trying to stress test multiple URLs using JMeter. The URLs are contained in a CSV file. I am not able to use the CSV Data Config set properly. Any suggestions on how to do the stress test?
9 years ago

Santhosh ayiappan wrote:You need to construct a XML with all the user details and return the xml as String to the caller.



Hi Santhosh,

Thanks for the reply. Would you please provide an example so that I could gain some insight as I am very new to web-services.

Or perhaps you could provide me a link where I could learn how to handle these cases.

Thanks again.
9 years ago
I am designing a web-service using java and eclipse which returns the user details who are marked as customer in the database.


GetData.java



LoginDetailsVO.java


On running the code I get object references like these: [[Ljava.lang.Object;@4d5575, [Ljava.lang.Object;@5585dc]
How can I get valid user details in place of object references? Please advice.

9 years ago

Winston Gutkowski wrote:
I'm also not sure if they set the value(s) permanently, or just for the current session



Hey man, thanks for the reply. I checked out the API and played around with it. It isn't permanent and exists only for the running process. Is there any way to make the changes permanent?
9 years ago
Hello everyone,

I was trying out this code which prints current system properties. Is there any method to create a new System properties value?

The code that prints current system properties are as follows:



Please advise.
9 years ago

Joanne Neal wrote:Try browsing these forums instead of the whole internet and you will find the exact same question asked (and answered) many times.



Thanks for the advice boss. Will do that.
9 years ago
While browsing the internet, I found a question something like this:

Is there any difference between:

String s="ABC";

and

String s=new String("ABC");

Though both of them assign ABC to the identifier s, is there actually any difference in the way the assignment takes place. Please advice.
9 years ago
Thanks for the reply guys, the problem is resolved.

I used the following code:

C:\beerV1>javac -cp C:\Tomcat_6.0\lib\servlet-api.jar; -d classes src/com/example/web/BeerSelect.java
9 years ago
Thanks for the reply.

The problem is now resolved. I created another server in Eclipse and it copied the server.xml of Tomcat!!! So, finally, SSL working with Eclipse. Thanks again for the replies.
9 years ago
Pheew, after a while the problem is now resolved. Changes to the server.xml (Tomcat) had already been made. I just created a new server within Eclipse. It imported the exact copy of Tomcat's server.xml. So, finally, SSL is working with eclipse. Thanks for the reply.

Peter Johnson wrote:From the output, it appears the the plugin is looking for the properties file in various locations (it even tells you where it is looking!), and cannot find the file in any of those places. (Hopefully this is enough of a hint...)



Hi John,

Thanks for the reply. The problem is now resolved. I copied the ESAPI.properties and the validator files in the home directory.
Hi,

Thanks for the reply. Yes, I have successfully configured SSL in Tomcat and all the necessary changes to the server.xml have been done.
Here's the copy of my server.xml document..

server.xml

9 years ago
Hello everyone,
I have been trying to configure SSL with Eclipse, but I keep getting the Page Cannot Be Displayed message. I have successful configured SSL with Tomcat as per the Tomcat 6.0 documentation.

The example that I created runs successful on my web-browser(outside Eclipse) but generates This Program Cannot Display the Webpage error message in Eclipse.
Here's the code for my example:-

Login.html



usingHttpsForm.html



UsingHttpsServlet.java



web.xml




Is there any other way to configure SSL in Tomcat? I tried to changed the server.xml of the default server in Eclipse workspace but after that the server failed to start in Eclipse. Please advice.