dipak jain

Greenhorn
+ Follow
since Dec 14, 2011
Merit badge: grant badges
For More
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
2
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by dipak jain

Hi Tim,
suggestions from experienced person never goes waste. It all depends on the user whether he wants to go with his own choice or would accept others opinion, but YES , after responses he can make his decisions better .
Thanks for your responses. I hope you can understand there was no time waste from my side. Please keep continue to post your suggestions/solutions , dont know you may be the problem killer for someone.
12 years ago
Yeah..anyway Thanks Tim for your valueble suggestion. I would keep continue with the struts 1 untill i get it on my par.
Please let us know if there are any good PDFs tutorial available because I dont hav access to internet in my project. I tried with the Struts Servival guide and with some Modification I was able to run my first struts application last night . Now I want some other tutorials to learn more about the struts.
12 years ago
upppps....... I would take care of Que mark next time...
Hope that somebuddy guide me on this as i started with the struts 1 and my Team lead told me to start with struts2 ...when i saw the struts 2 i got confuse whether i shuld read struts1 firstly or can i directly jump to struts2..
12 years ago
I am newbie to Struts...should i start with struts1 or struts2???/
12 years ago
Hello,
I got to know the error why this code was nt runnning for index.jsp.......I fixed the spell mistake and it start working. Now I am getting another error . please advise.
message /App1CustomerDetails.jsp

description The requested resource (/App1CustomerDetails.jsp) is not available.

Please see the code in my early post (I made the spell corrections) and advise me on the same.Thanks All.
12 years ago
I rechecked the code and observed that the issue is my program is getting error out while Just control goes from Index.jsp ...Most likely reason is HTML tag. I tried with the <a href..></a> the page worked and control goes to another JSP but when I tried to use <html:link >it didnt worked. Please review it and advise me .

I tried the above code by changing the <%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
12 years ago
Hello Paul,
Thanks for your help. I did fix the name of classes in config file ...but still i am getting the same error . I copied the below error details from Tomcat 6.0 log :

Dec 15, 2011 4:39:59 AM org.apache.catalina.core.StandardContext loadOnStartup
SEVERE: Servlet /App1 threw load() exception
java.lang.ClassNotFoundException: org.apachi.struts.action.ActionServlet
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1360)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1206)

Please see this and advise me if I need to add any other jar files. Netbeans 6.0 provides all the required Jar for an application.
12 years ago

Hi, I am getting the below execption while running my struts application . please advise, how to solve it.
I am using Netbeans6.0 , tomcat6.0, struts1.3...i have used all the required jarfiles and xmls.



When I am running the app , getting exception like:
description The server encountered an internal error () that prevented it from fulfilling this request.

exception

org.apache.jasper.JasperException: java.lang.NullPointerException: Module 'null' not found.
org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServletWrapper.java:522)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:416)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:337)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
org.netbeans.modules.web.monitor.server.MonitorFilter.doFilter(MonitorFilter.java:390)
root cause

java.lang.NullPointerException: Module 'null' not found.
org.apache.struts.taglib.TagUtils.getModuleConfig(TagUtils.java:755)
org.apache.struts.taglib.TagUtils.computeURLWithCharEncoding(TagUtils.java:364)
org.apache.struts.taglib.TagUtils.computeURLWithCharEncoding(TagUtils.java:285)
org.apache.struts.taglib.html.LinkTag.calculateURL(LinkTag.java:445)
org.apache.struts.taglib.html.LinkTag.doEndTag(LinkTag.java:353)
org.apache.jsp.index_jsp._jspx_meth_html_005flink_005f0(index_jsp.java:168)
org.apache.jsp.index_jsp._jspx_meth_html_005fhtml_005f0(index_jsp.java:106)
org.apache.jsp.index_jsp._jspService(index_jsp.java:70)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:337)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
org.netbeans.modules.web.monitor.server.MonitorFilter.doFilter(MonitorFilter.java:390)
-----------------------------------struts.xml------->


Any help would be highly appreciated.
12 years ago