Well, currently your ResizeImage method (should be resizeImage, to fit with standard naming practices) accepts both a path and a byte.
When you want the default image then, if byte is null, give that method the path to the default image instead.
Indeed, I would split the resizeImage up. It's currently doing too much, in my opinion.
First, the resize:
Then supply two methods to get an image:
Depending on where these live, I wouldn't expect them to be public methods, but I don't know your code structure.
ETA: This lot is hand written, so apologies for any compilation issues.