Stefan Evans wrote:Actually, my solution would have been :
But then I like stepping through code with a debugger, and this format lets you stop and inspect the return value of the method very easily, whereas your first example doesn't directly.
Liutauras Vilda wrote:I'd suggest you to choose variable names more carefully: day, nextDay, nextDate it's rather confusing and error prone. You can easily misplace variable and it would take hours to find out what is wrong.
Stijn Rensen wrote:Is this also good coding practice?
Liutauras Vilda wrote:
Stijn Rensen wrote:Or is this adjustment purely to positively influence the mood of eclipse?
Nothing is wrong with Ecplise, actually it says what it is. In any expression you never used this nextDate variable.