Last week, we had the author of TDD for a Shopping Website LiveProject. Friday at 11am Ranch time, Steven Solomon will be hosting a live TDD session just for us. See for the agenda and registration link

marius tanislav

Greenhorn
+ Follow
since Apr 23, 2015
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by marius tanislav

Hi,
I like to configure an Jboss As 7.1.1 in domain mode.I have 1 host acting as domain controller(192.168.77.139) and other host as host controller(192.168.77.219).
Below is the domain.xml and host.xml on domain controller.
domain.xml
<deployments>
<deployment name="sample.war" runtime-name="sample.war">
<content sha1="80f5053b166c69d81697ba21113c673f8372aca0"/>
</deployment>
</deployments>

<server-groups>
<server-group name="multi" profile="ha">
<jvm name="default">
<heap size="64m" max-size="512m"/>
</jvm>
<socket-binding-group ref="ha-sockets"/>
<deployments>
<deployment name="sample.war" runtime-name="sample.war"/>
</deployments>

host.xml
<host name="ousor" xmlns="urn:jboss:domain:1.2">
<domain-controller>
<local/>
<interface name="management">
<inet-address value="${jboss.bind.address.management:192.168.77.139}"/>
</interface>
<interface name="public">
<inet-address value="${jboss.bind.address:192.168.77.139}"/>
</interface>
<servers>
<server name="purcelas" group="multi" auto-start="true">
<socket-bindings port-offset="100"/>
<server name="porcusor" group="multi" auto-start="true">
<socket-bindings port-offset="200"/>
</server>

now host controller has:
host.xml
<host name="master" xmlns="urn:jboss:domain:1.2">
<domain-controller>
<remote host="192.168.77.139" port="9999"/>
<interfaces>
<interface name="management">
<inet-address value="${jboss.bind.address.management:192.168.77.139}"/>
</interface>
<interface name="public">
<inet-address value="${jboss.bind.address:192.168.77.139}"/>
</interface>
<servers>
<server name="porcusor" group="multi" auto-start="true">
<socket-bindings port-offset="200"/>

i start the domain controller bin/domain.sh -b 192.168.77.139.Everything is fine and the sample.war is registered to server porcusor and purcelas.
i start the host controller on 192.168.77.219 like /bin/domain.sh -b 192.168.77.219 -Djboss.domain.master.address=192.168.77.139 -Djboss.domain.master.port=9999

and i have the error on the host controller console:
/bin/bash: indent: command not found
ss Bootstrap Environment

JBOSS_HOME: /jboss-as-7.1.1.Final

JAVA: java

JAVA_OPTS: -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Djboss.domain.default.config=domain.xml -Djboss.host.default.config=host.xml

=========================================================================

09:21:33,693 INFO [org.jboss.modules] (main) JBoss Modules version 1.1.1.GA
09:21:34,564 INFO [org.jboss.as.process.Host Controller.status] (main) JBAS012017: Starting process 'Host Controller'
[Host Controller] 09:21:38,521 INFO [org.jboss.modules] (main) JBoss Modules version 1.1.1.GA
[Host Controller] 09:21:39,483 INFO [org.jboss.msc] (main) JBoss MSC version 1.0.2.GA
[Host Controller] 09:21:40,240 INFO [org.jboss.as] (MSC service thread 1-1) JBAS015899: JBoss AS 7.1.1.Final "Brontes" starting
[Host Controller] 09:21:45,978 INFO [org.xnio] (MSC service thread 1-1) XNIO Version 3.0.3.GA
[Host Controller] 09:21:46,170 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC00001: Failed to start service jboss.network.management: org.jboss.msc.service.StartException in service jboss.network.management: JBAS015810: failed to resolve interface management
[Host Controller] at org.jboss.as.server.services.net.NetworkInterfaceService.start(NetworkInterfaceService.java:97) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
[Host Controller] at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
[Host Controller] at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
[Host Controller] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_79]
[Host Controller] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_79]
[Host Controller] at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_79]
[Host Controller]
[Host Controller] 09:21:46,521 INFO [org.xnio.nio] (MSC service thread 1-1) XNIO NIO Implementation Version 3.0.3.GA
[Host Controller] 09:21:46,799 INFO [org.jboss.remoting] (MSC service thread 1-1) JBoss Remoting version 3.2.3.GA
[Host Controller] 09:21:47,467 INFO [org.jboss.as.controller] (MSC service thread 1-2) JBAS014774: Service status report
[Host Controller] JBAS014777: Services which failed to start: service jboss.network.management: org.jboss.msc.service.StartException in service jboss.network.management: JBAS015810: failed to resolve interface management
[Host Controller]


please guide me.
thanks,
marius

7 years ago
i do not see the solved button.
7 years ago
thanks and there is no solved button.
7 years ago
before to close this thread just something.
in server.xml how do i know what kind of conector(jsse or apr) i should configure?i mean what command should i use to see it?
i created an jks keystore with keytool -keygen -alias "name" -keygen RSA and i used within the connector as in my first page of this thread.should i use instead an pem format of keystore?
thanks,
marius
7 years ago
Hi Tim,
The error is 404 when i try http://www.vucni.com:8080/manager/html.even if i have #taill -f catalina.out,there is no error message.the same on the rest of logs.
catalina.out is:
May 05, 2015 5:11:20 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8080"]
May 05, 2015 5:11:20 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-bio-8009"]
May 05, 2015 5:11:20 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 17484 ms

war deployment.
server.xml is:
<Host name="vucni66.localdomain" appBase="u"
unpackWARs="true" autoDeploy="true">
</Host>

if i copy a war file under "u" directory and restart tomcat then i have the file deployed.
thanks,
marius
7 years ago
hi,
i wish to configure the tomcat manager application and i encounter issue.
bin/tomcat-users.xml is:
<role rolename="admin"/>
<role rolename="admin-gui"/>
<role rolename="manager-gui"/>
<user username="tomcat" password="tomcat" roles="admin,admin-gui,manager-gui" />

server.xml
<Host name="www.ousor.com" appBase="webapps" unpackWAR="true" autoDeploy="true">

www.ousor.com ->192.168.77.142

conf/Catalina/www.ousor.com/manager.xml
<Context privileged="true" docBase="/root/apache-tomcat-7.0.61/webapps"
<Valva className="org.apache.catalina.valves.RemoteAddrValve"
allow="192\.168\.77\142" />
>

http://www.ousor.com:8080 is working but when i try to click on manager application button i receive error.
the same error if i try http://www.ousor.com:8080/manager/html

when i deploy an war file let`s say under /u directory,by command line,first i copy it under webapp directory and then i copy from here to /u directory.
if i copy war file directly under /u then no expanded directory will be.
is there other way to deploy by command line a war file under /u?
thans,
marius
7 years ago
Hi Tim,
Before i close this thread i like to clarify something.

i configured httpd.conf like below:
Listen 99
<VirtualHost *:99>
ServerName www.vucni.com
ProxyPass /u http://vucni66.localdomain:8000/u/sample/
ProxyPassReverse /u http://vucni66.localdomain:8000/u/sample/
ProxyPass /v http://localhost:8443
ProxyPassReverse /v http:://localhost:8443
SSLEngine on
SSLProxyEngine on
SSLCertificateFile "/etc/httpd/cacert.pem"
SSLCertificateKeyFile "/etc/httpd/privkey.pem"
</VirtualHost>


I configured server.xml with connector 8000 like below and in this case apache+ssl and tomcat is working.-https://www.vucni.com:99/u/

<Connector port="8000" protocol="HTTP/1.1"
connectionTimeout="20000" enableLookups="false" acceptCount="100" proxyPort="99" />
If i configure the connector 8000 like below,it does not works.Please why?

<Connector port="8000"
maxThreads="150" SSLEnabled="false" scheme="https" secure="false"
proxyPort="99"
proxyName="www.vucni.com"
enableLookups="true" acceptCount="100" />


<Host name="vucni66.localdomain" appBase="u"
unpackWARs="true" autoDeploy="true">
</Host>
Context file is u.xml in conf/Catalina/vucni66.localdomain/
<Context docBase="/root/apache-tomcat-7.0.61/u" />




thanks,
marius
7 years ago
hi,
i like to access my index.xml file placed in /root/apache-tomcat-7.0.61/webapps/u/ROOT/index.xml using the context.
if i put the context inside the server.xml everything is fine: http://vucni66.localdomain:8080/u/ or http://vucni66.localdomain:8080/v/
if i put u.xml like /root/apache-tomcat-7.0.61/conf/Catalina/vucni66.localdomain/u.xml or /root/apache-tomcat-7.0.61/webapps/u/META-INF/u.xml then does not works.Please why?


outpput of u.xml:
/root/apache-tomcat-7.0.61/webapps/u/ROOT/index.xml
</Context>

output of server.xml:
<Host name="vucni66.localdomain" appBase="webapps"
unpackWARs="true" autoDeploy="true">

<Context path="/u" docBase="/root/apache-tomcat-7.0.61/webapps/u/ROOT" />
<Context path="/v" docBase="/root/apache-tomcat-7.0.61/webapps/v/ROOT" />
</Context>

</Host>


note:
also i tried with /u path outside of /webapps and the same it does not works. /root/apache-tomcat-7.0.61/u/ROOT/index.xml and <Context path="/u" docBase="/root/apache-tomcat-7.0.61/u/ROOT" />


thanks,marius
7 years ago
Hi Tim,
i wish to close this thread,but before just a thing.
i installed tomcat again and netstat -tulpn shows that tomcat not listen on port 8443.how could i start port 8443 with tomcat?


Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1459/sshd
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 1342/cupsd
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 1568/master
tcp 0 0 :::22 :::* LISTEN 1459/sshd
tcp 0 0 ::1:631 :::* LISTEN 1342/cupsd
tcp 0 0 ::ffff:127.0.0.1:8005 :::* LISTEN 2104/java
tcp 0 0 :::8009 :::* LISTEN 2104/java
tcp 0 0 :::8080 :::* LISTEN 2104/java
udp 0 0 0.0.0.0:68 0.0.0.0:* 1339/dhclient
udp 0 0 0.0.0.0:631 0.0.0.0:* 1342/cupsd


<Connector port="8080" protocol="HTTP/1.1"
connectionTimeout="20000"
redirectPort="8443" />
<!-- A "Connector" using the shared thread pool-->
<!--
<Connector executor="tomcatThreadPool"
port="8080" protocol="HTTP/1.1"
connectionTimeout="20000"
redirectPort="8443" />
<!-- A "Connector" using the shared thread pool-->
<!--
<Connector executor="tomcatThreadPool"
port="8080" protocol="HTTP/1.1"
connectionTimeout="20000"
redirectPort="8443" />
-->
<!-- Define a SSL HTTP/1.1 Connector on port 8443
This connector uses the BIO implementation that requires the JSSE
style configuration. When using the APR/native implementation, the
OpenSSL style configuration is required as described in the APR/native
documentation -->
<Connector port="8443" protocol="org.apache.coyote.http11.Http11Protocol"
maxThreads="150" SSLEnabled="true" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS"
SSLCertificateFile="/root/apache-tomcat-7.0.61/cert.pem"
SSLCertificateKeyFile="/root/apache-tomcat-7.0.61/key.pem"
SSLPassword="ousor11" />
<!-- Define an AJP 1.3 Connector on port 8009 -->
<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />

<Host name="localhost" appBase="webapps"
unpackWARs="true" autoDeploy="true">
</Host>

i think after i uncomment the connector 8443 and restart tomcat,i should see port 8443 open but i am not able to see it.why?
thanks,
marius
7 years ago
Hi Tim,
i am sorry that i wrote mistakenly in server.xml.
correct is
<Connector port="8080" protocol="HTTP/1.1"
connectionTimeout="20000"
redirectPort="8443" />


<Host name="localhost" appBase="webapps"
unpackWARs="true" autoDeploy="true">
</Host>

even in this case when i have apache and tomcat on the same server,i am not able to retrieve my index.html file.i have ssl+apache and plain tomcat.
is https://www.vucni.com:80 correct to access index.html?

is better to use mod_proxy instead mod_jk in this case or when i use apache as loadbalancer?
thanks,
marius
7 years ago
hi,
i wish to verify why my apache with ssl and my my tomcat does not access the index.html.
my file is /root/apache-tomcat-7.0.59/u/ROOT.index.html
the ssl apache is working -https://www.vucni.com:443 and tomcat also http://www.vucni.8080
i know that when using ssl with apache as front end and tomcat as back end,only apache need to be set up with ssl and tomcat no.right?



my httpd.conf file is:
Listen 80 ;i do not think i should add also Listen 443
JkWorkersFile /etc/httpd/conf/workers.properties
LoadModule ssl_module modules/mod_ssl.so
LoadModule jk_module modules/mod_jk.so
ServerName localhost
<VirtualHost *:443>
SSLEngine on
SSLCertificateFile /etc/httpd/cacert.pem
SSLCertificateKeyFile /etc/httpd/privkey.pem
JkMount /u ajp13
JkMount /u/* ajp13
DocumentRoot /root/apache-tomcat-7.0.59/u
ServerName www.vucni.com
</VirtualHost>

worker.properties
worker.list=ajp13
worker.ajp13.type=ajp13
worker.ajp13.host=localhost
worker.ajp13.port=8009


server.xml
<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />
<Connector port="8443" protocol="org.apache.coyote.http11.Http11Protocol"
maxThreads="150" SSLEnabled="true" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS" />
<Host name="www.vucni.com" appBase="u"
unpackWARs="true" autoDeploy="true">
</Host>

i try https://www.vucni.com:80 and i have error.is this how i should to access the index.html content?
thanks,
marius
7 years ago
Hi Tim.


wget https://www.vucni.com:8443

--2015-04-25 06:48:24-- https://www.vucni.com:8443/
Resolving www.vucni.com... 192.168.77.139
Connecting to www.vucni.com|192.168.77.139|:8443... connected.
ERROR: cannot verify www.vucni.com’s certificate, issued by “/C=o/ST=o/L=o/O=o/OU=o/CN=www.vucni.com”:
Self-signed certificate encountered.
To connect to www.vucni.com insecurely, use ‘--no-check-certificate’.

So the connection is made but the error tells that i have an Self-signed certificate.
fine,in this case https on 8443 will not works?i saw many articles were they write that https on 8443 should works.
i MUST have an signed certificate from an CA ?


other question is when i create :
keytool -genkey -alias tomcat -keyalg RSA
what is your first and last name: HERE IF I WRITE "mt" AND NOT WWW.VUCNI.COM,when i perform wget like below,


i have the error:-ERROR: certificate common name “mt” doesn't match requested host name “www.vucni.com”.

so at "what is your last and first name?" what should i write?

wget https://www.vucni.com:8443
--2015-04-25 06:52:51-- https://www.vucni.com:8443/
Resolving www.vucni.com... 192.168.77.139
Connecting to www.vucni.com|192.168.77.139|:8443... connected.
ERROR: cannot verify www.vucni.com’s certificate, issued by “/C=Unknown/ST=Unknown/L=Unknown/O=Unknown/OU=Unknown/CN=mt”:
Self-signed certificate encountered.
ERROR: certificate common name “mt” doesn't match requested host name “www.vucni.com”.
To connect to www.vucni.com insecurely, use ‘--no-check-certificate’.

the output of keytool -list -v keystore

Keystore type: JKS
Keystore provider: SUN

Your keystore contains 1 entry

Alias name: tomcat
Creation date: Apr 25, 2015
Entry type: PrivateKeyEntry
Certificate chain length: 1
Certificate[1]:
Owner: CN=www.vucni.com, OU=o, O=o, L=o, ST=o, C=o
Issuer: CN=www.vucni.com, OU=o, O=o, L=o, ST=o, C=o
Serial number: 6a3d3daa
Valid from: Sat Apr 25 06:29:43 PDT 2015 until: Fri Jul 24 06:29:43 PDT 2015
Certificate fingerprints:
MD5: 3D:E9:67:A1:12:96:26:D7:BC:E0:36:55:58:5D:81:62
SHA1: 5A:8D:22:45:64:59:48:43:ED:61:7E:AF:8D:23:8B:B9:D2:80:4E:F4
SHA256: BC:C8:37:C9:E0:12:F1:1F:E9:BC:81:11:C1:5C:6F:E3:65:11:77:31:24:B8:05:01:84:0D:09:0C:D2:93:F6:52
Signature algorithm name: SHA256withRSA
Version: 3

Extensions:

#1: ObjectId: 2.5.29.14 Criticality=false
SubjectKeyIdentifier [
KeyIdentifier [
0000: 9C A7 63 CE 70 9A 7F EF B2 5E 96 84 55 76 FF 85 ..c.p....^..Uv..
0010: 71 78 DF C7 qx..
]
]



*******************************************
*******************************************




thanks,
marius


7 years ago
Hi Tim,
The output of netstat -tulpn:
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1504/sshd
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 1355/cupsd
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 1613/master
tcp 0 0 :::22 :::* LISTEN 1504/sshd
tcp 0 0 ::1:631 :::* LISTEN 1355/cupsd
tcp 0 0 :::8443 :::* LISTEN 2207/java
tcp 0 0 ::ffff:127.0.0.1:8005 :::* LISTEN 2207/java
tcp 0 0 :::8009 :::* LISTEN 2207/java
tcp 0 0 :::8080 :::* LISTEN 2207/java
udp 0 0 0.0.0.0:68 0.0.0.0:* 1349/dhclient
udp 0 0 0.0.0.0:631 0.0.0.0:* 1355/cupsd

so tomcat listen on 8443,8009,8080.
when i try to connect from browser like : https://www.vucni.com:8446 the error is "Issuer certificate is invalid" (error code: sec_error_ca_cert_invalid).
the output of ls -l keynew
-rw-r--r--. 1 root root 2181 Apr 23 10:10 /root/keynew

curl -LI https://www.vucni.com:8443/ gives:

curl (77) problem with SSL CA cert (path? access right?)

catalina.out
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.SetAllPropertiesRule begin
WARNING: [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'KeystorePassword' to 'changeit' did not find a matching property.
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Server version: Apache Tomcat/7.0.59
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Server built: Jan 28 2015 15:51:10 UTC
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Server number: 7.0.59.0
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: OS Name: Linux
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: OS Version: 2.6.32-504.el6.i686
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Architecture: i386
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Java Home: /jdk1.7.0_79/jre
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: JVM Version: 1.7.0_79-b15
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: JVM Vendor: Oracle Corporation
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: CATALINA_BASE: /root/apache-tomcat-7.0.59
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: CATALINA_HOME: /root/apache-tomcat-7.0.59
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Command line argument: -Djava.util.logging.config.file=/root/apache-tomcat-7.0.59/conf/logging.properties
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Command line argument: -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Command line argument: -Djava.endorsed.dirs=/root/apache-tomcat-7.0.59/endorsed
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Command line argument: -Dcatalina.base=/root/apache-tomcat-7.0.59
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Command line argument: -Dcatalina.home=/root/apache-tomcat-7.0.59
Apr 24, 2015 9:03:50 AM org.apache.catalina.startup.VersionLoggerListener log
INFO: Command line argument: -Djava.io.tmpdir=/root/apache-tomcat-7.0.59/temp
Apr 24, 2015 9:03:50 AM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/java/packages/lib/i386:/lib:/usr/lib
Apr 24, 2015 9:03:51 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8080"]
Apr 24, 2015 9:03:51 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8443"]
Apr 24, 2015 9:03:52 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
Apr 24, 2015 9:03:52 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 3976 ms
Apr 24, 2015 9:03:52 AM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
Apr 24, 2015 9:03:52 AM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.59
Apr 24, 2015 9:03:52 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory /root/apache-tomcat-7.0.59/u/ROOT
Apr 24, 2015 9:03:54 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory /root/apache-tomcat-7.0.59/u/ROOT has finished in 1,932 ms
Apr 24, 2015 9:03:54 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory /root/apache-tomcat-7.0.59/webapps/ROOT
Apr 24, 2015 9:03:55 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory /root/apache-tomcat-7.0.59/webapps/ROOT has finished in 507 ms
Apr 24, 2015 9:03:55 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory /root/apache-tomcat-7.0.59/webapps/examples
Apr 24, 2015 9:03:57 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory /root/apache-tomcat-7.0.59/webapps/examples has finished in 2,083 ms
Apr 24, 2015 9:03:57 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory /root/apache-tomcat-7.0.59/webapps/docs
Apr 24, 2015 9:03:57 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory /root/apache-tomcat-7.0.59/webapps/docs has finished in 243 ms
Apr 24, 2015 9:03:57 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory /root/apache-tomcat-7.0.59/webapps/host-manager
Apr 24, 2015 9:03:58 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory /root/apache-tomcat-7.0.59/webapps/host-manager has finished in 325 ms
Apr 24, 2015 9:03:58 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory /root/apache-tomcat-7.0.59/webapps/manager
Apr 24, 2015 9:03:58 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory /root/apache-tomcat-7.0.59/webapps/manager has finished in 324 ms
Apr 24, 2015 9:03:58 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8080"]
Apr 24, 2015 9:03:58 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8443"]
Apr 24, 2015 9:03:58 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-bio-8009"]
Apr 24, 2015 9:03:58 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 5856 ms





localhost.log

Apr 24, 2015 9:03:57 AM org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
Apr 24, 2015 9:03:57 AM org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
Apr 24, 2015 9:03:57 AM org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: attributeAdded('org.apache.jasper.compiler.TldLocationsCache', 'org.apache.jasper.compiler.TldLocationsCache@cd634')

thanks,
marius
7 years ago
Hi Tim,

i ran iptables -F,so the firewall is fine.
netstat -tulp output is:
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:ssh *:* LISTEN 1461/sshd
tcp 0 0 localhost:ipp *:* LISTEN 1345/cupsd
tcp 0 0 localhost:smtp *:* LISTEN 1601/master
tcp 0 0 *:ssh *:* LISTEN 1461/sshd
tcp 0 0 localhost:ipp *:* LISTEN 1345/cupsd
tcp 0 0 localhost:mxi *:* LISTEN 2111/java
tcp 0 0 *:8009 *:* LISTEN 2111/java
tcp 0 0 *:webcache *:* LISTEN 2111/java
udp 0 0 *:bootpc *:* 1340/dhclient
udp 0 0 *:ipp *:* 1345/cupsd


so no port 8443 open.how i will be able to open it?in rest what i have done is correct?thanks.
marius
7 years ago
hi,
i wish to configure https on tomcat.i have done as below:
keytool -genkey -alias tomcat -keyalg RSA -keystore /etc/pki/keystore ;the keystore password as tomcat password is changeit.
in server.xml
<Connector
protocol="org.apache.coyote.http11.Http11Protocol"
port="8443" maxThreads="200"
scheme="https" secure="true" SSLEnabled="true"
keystoreFile="/etc/pki/keystore" keystorePass="changeit"
clientAuth="false" sslProtocol="TLS"/>

<Host name="www.test.com" appBase="webapps"
unpackWARs="true" autoDeploy="true">
</Host>

ido not have inlib the libtcnative library.

then i try https://www.test.com:8443/ and i am not able to connect/
thanks
marius
7 years ago