Win a copy of Rust Web Development this week in the Other Languages forum!

chicquie Kumar

Greenhorn
+ Follow
since Sep 22, 2018
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
4
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by chicquie Kumar

Hi Team,

I have configured new weblogic server with 12.2.1.3 and created domain for SOA suite. Everything went smooth duruing installation and configuration and my WLS_SOA1 and WLS_SOA2 is in running state, but when i went to deployment section in admin console and check soa_infra, i am seeing it in failed state. Pl check the attach screenshot of failed soa_infra.



Please let me know how i can bring it up.

Thanks
3 years ago
This is the error

Bean weblogic.management.configuration.MigratableTargetMBeanImpl@c1872522([soadomain]/MigratableTargets[WLS_SOA1 (migratable)]) references [WLS_SOA1 (migratable) by [soadomain]/JMSServers[UMSJMSServer_auto_1]/Targets, WLS_SOA1 (migratable) by [soadomain]/JMSServers[BPMJMSServer_auto_1]/Targets, WLS_SOA1 (migratable) by [soadomain]/JMSServers[SOAJMSServer_auto_1]/Targets, WLS_SOA1 (migratable) by [soadomain]/JDBCStores[UMSJMSJDBCStore_auto_1]/Targets, WLS_SOA1 (migratable) by [soadomain]/JDBCStores[BPMJMSJDBCStore_auto_1]/Targets, WLS_SOA1 (migratable) by [soadomain]/JDBCStores[SOAJMSJDBCStore_auto_1]/Targets]
Message icon - Error Errors must be corrected before proceeding.
3 years ago
Hi Team,

I have setup hortizontal clustering for which i have one cluster BAM_CLUSTER in which WLS_SOA1, WLS_SOA2, WLS_BAM1 and WLS_BAM2 is there. I created a new cluster SOA_CLUSTER from admin console and trying to delete the managed server (WLS_SOA1 and WLS_SOA2) from BAM_CLUSTER, but it throwing error as

Message icon - Error The following failures occurred: -- The cluster of the preferred server of MigratableTargetMBean WLS_WSM2_bam-exactly-once (migratable) is not set.
Message icon - Error Errors were encountered while performing this operation.

Why i am unable to change managed server from one cluster to another. Please suggest. I want to change WLS_SOA1 and WLS_SOA2 in SOA_CLUSTER. please tell me how i can do this.

Thanks
3 years ago
Dear Morris, i had checked with telnet for port 7010 and it was working for me. Now server is up and running just i changed the listen address from hostname (dspdrfghvsn) to IP of hostname (10.11.11.11), because in nodemanager machine2 listnen address i have given as hostname ip.

Thanks
3 years ago
Dear Morris,

This issue is resolved. I had mentioned the listen address in WLS_SOA2 and WLS_WSM2 as hostname and in nodemanager i had given listen address as ip of hostname. So it was giving error.

I am still confused, though my issue is resolved but my confusion is still there. In WLS_SOA1 and WLS_WSM1 in server i have given hostname, and Nodemanager i have given ip of hostname but there it started up without any issue.

Please suggest.. But now i am able to see status of WLS_SOA2 and WLS_WSM2 as running.

Thanks
3 years ago
Hi Morris,

When i checked the log of WLS_SOA2 i found one error

####<Sep 24, 2018 8:21:31,170 PM GST> <Error> <RJVM> <10.11.11.11> <WLS_SOA2> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <f7a02eef-299e-480d-94fa-b2065a7926ab-0000012e> <1537806091170> <[severity-value: 8] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000580> <Failed to send JVMMessage from: '1094830830832753378S:dbpdcpciapvn574:soadomain:WLS_SOA2' to: '2909173254129217458S:172.31.205.141:[7001,-1,-1,-1,-1,-1,-1]:soadomain:AdminServer' cmd: 'CMD_IDENTIFY_REQUEST', QOS: '101', responseId: '-1', invokableId: '-1', flags: 'JVMIDs Sent, TX Context Not Sent, 0x0', abbrev offset: '171'.
java.io.IOException: Attempt to send message on closed socket
java.io.IOException: Attempt to send message on closed socket
       at weblogic.rjvm.t3.MuxableSocketT3$T3MsgAbbrevJVMConnection.sendMsg(MuxableSocketT3.java:817)
       at weblogic.rjvm.MsgAbbrevJVMConnection.sendOutMsg(MsgAbbrevJVMConnection.java:389)
       at weblogic.rjvm.MsgAbbrevJVMConnection.sendMsg(MsgAbbrevJVMConnection.java:223)
       at weblogic.rjvm.MsgAbbrevJVMConnection.sendMsg(MsgAbbrevJVMConnection.java:173)
       at weblogic.rjvm.ConnectionManager.findOrCreateConnection(ConnectionManager.java:1742)
       at weblogic.rjvm.ConnectionManager.findOrCreateConnection(ConnectionManager.java:1418)
       at weblogic.rjvm.ConnectionManager.sendMsg(ConnectionManager.java:614)
       at weblogic.rjvm.RJVMImpl.send(RJVMImpl.java:1168)
       at weblogic.rjvm.MsgAbbrevOutputStream.flushAndSend(MsgAbbrevOutputStream.java:448)
       at weblogic.rjvm.MsgAbbrevOutputStream.sendRecv(MsgAbbrevOutputStream.java:458)
       at weblogic.rjvm.BasicOutboundRequest.sendReceive(BasicOutboundRequest.java:128)
       at weblogic.rmi.internal.BasicRemoteRef.invoke(BasicRemoteRef.java:299)
       at weblogic.server.RemoteLifeCycleOperationsImpl_12213_WLStub.getState(Unknown Source)
       at weblogic.server.channels.RemoteChannelServiceImpl.getServerState(RemoteChannelServiceImpl.java:633)
       at weblogic.server.channels.RemoteChannelServiceImpl.access$500(RemoteChannelServiceImpl.java:70)
       at weblogic.server.channels.RemoteChannelServiceImpl$2.run(RemoteChannelServiceImpl.java:275)
       at weblogic.server.channels.RemoteChannelServiceImpl$2.run(RemoteChannelServiceImpl.java:273)
       at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:368)
       at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:163)
       at weblogic.server.channels.RemoteChannelServiceImpl.registerInternal(RemoteChannelServiceImpl.java:273)
       at weblogic.server.channels.RemoteChannelServiceImpl.access$200(RemoteChannelServiceImpl.java:70)
       at weblogic.server.channels.RemoteChannelServiceImpl$TimerListenerImpl.timerExpired(RemoteChannelServiceImpl.java:176)
       at weblogic.timers.internal.TimerImpl.run(TimerImpl.java:301)
       at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:670)
       at weblogic.invocation.ComponentInvocationContextManager._runAs(ComponentInvocationContextManager.java:352)
       at weblogic.invocation.ComponentInvocationContextManager.runAs(ComponentInvocationContextManager.java:337)
       at weblogic.work.LivePartitionUtility.doRunWorkUnderContext(LivePartitionUtility.java:57)
       at weblogic.work.PartitionUtility.runWorkUnderContext(PartitionUtility.java:41)
       at weblogic.work.SelfTuningWorkManagerImpl.runWorkUnderContext(SelfTuningWorkManagerImpl.java:644)
       at weblogic.work.ExecuteThread.execute(ExecuteThread.java:415)
       at weblogic.work.ExecuteThread.run(ExecuteThread.java:355)
>
####<Sep 24, 2018 8:21:41,192 PM GST> <Error> <RJVM> <10.11.11.11> <WLS_SOA2> <[ACTIVE] ExecuteThread: '51' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <f7a02eef-299e-480d-94fa-b2065a7926ab-00000132> <1537806101192> <[severity-value: 8] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000580> <Failed to send JVMMessage from: '1094830830832753378S:dbpdcpciapvn574:soadomain:WLS_SOA2' to: '2909173254129217458S:172.31.205.141:[7001,-1,-1,-1,-1,-1,-1]:soadomain:AdminServer' cmd: 'CMD_IDENTIFY_REQUEST', QOS: '101', responseId: '-1', invokableId: '-1', flags: 'JVMIDs Sent, TX Context Not Sent, 0x0', abbrev offset: '171'.
java.io.IOException: Attempt to send message on closed socket
java.io.IOException: Attempt to send message on closed socket
       at weblogic.rjvm.t3.MuxableSocketT3$T3MsgAbbrevJVMConnection.sendMsg(MuxableSocketT3.java:817)
       at weblogic.rjvm.MsgAbbrevJVMConnection.sendOutMsg(MsgAbbrevJVMConnection.java:389)
       at weblogic.rjvm.MsgAbbrevJVMConnection.sendMsg(MsgAbbrevJVMConnection.java:223)
       at weblogic.rjvm.MsgAbbrevJVMConnection.sendMsg(MsgAbbrevJVMConnection.java:173)
       at weblogic.rjvm.ConnectionManager.findOrCreateConnection(ConnectionManager.java:1742)
       at weblogic.rjvm.ConnectionManager.findOrCreateConnection(ConnectionManager.java:1418)
       at weblogic.rjvm.ConnectionManager.sendMsg(ConnectionManager.java:614)
       at weblogic.rjvm.RJVMImpl.send(RJVMImpl.java:1168)
       at weblogic.rjvm.MsgAbbrevOutputStream.flushAndSend(MsgAbbrevOutputStream.java:448)
       at weblogic.rjvm.MsgAbbrevOutputStream.sendRecv(MsgAbbrevOutputStream.java:458)
       at weblogic.rjvm.BasicOutboundRequest.sendReceive(BasicOutboundRequest.java:128)
       at weblogic.rmi.internal.BasicRemoteRef.invoke(BasicRemoteRef.java:299)
       at weblogic.server.RemoteLifeCycleOperationsImpl_12213_WLStub.getState(Unknown Source)
       at weblogic.server.channels.RemoteChannelServiceImpl.getServerState(RemoteChannelServiceImpl.java:633)
       at weblogic.server.channels.RemoteChannelServiceImpl.access$500(RemoteChannelServiceImpl.java:70)
       at weblogic.server.channels.RemoteChannelServiceImpl$2.run(RemoteChannelServiceImpl.java:275)
       at weblogic.server.channels.RemoteChannelServiceImpl$2.run(RemoteChannelServiceImpl.java:273)
       at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:368)
       at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:163)
       at weblogic.server.channels.RemoteChannelServiceImpl.registerInternal(RemoteChannelServiceImpl.java:273)
       at weblogic.server.channels.RemoteChannelServiceImpl.access$200(RemoteChannelServiceImpl.java:70)
       at weblogic.server.channels.RemoteChannelServiceImpl$TimerListenerImpl.timerExpired(RemoteChannelServiceImpl.java:176)
       at weblogic.timers.internal.TimerImpl.run(TimerImpl.java:301)
       at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:670)
       at weblogic.invocation.ComponentInvocationContextManager._runAs(ComponentInvocationContextManager.java:352)
       at weblogic.invocation.ComponentInvocationContextManager.runAs(ComponentInvocationContextManager.java:337)
       at weblogic.work.LivePartitionUtility.doRunWorkUnderContext(LivePartitionUtility.java:57)
       at weblogic.work.PartitionUtility.runWorkUnderContext(PartitionUtility.java:41)
       at weblogic.work.SelfTuningWorkManagerImpl.runWorkUnderContext(SelfTuningWorkManagerImpl.java:644)
       at weblogic.work.ExecuteThread.execute(ExecuteThread.java:415)
       at weblogic.work.ExecuteThread.run(ExecuteThread.java:355)
(ExecuteThread.java:355)
>


Thanks
3 years ago
Hi Morris,

Yes i am able to ping both machine from one another. I am able to start the server from admin console also. WLS_WSM1 in machine 1 has port 7010 and WLS_WSM2 in machine 2 has port 7010. As both are in different machine that is why i kept port 7010 in both machine. I extended domain for soa suite in this domain. I am seeing same for WLS_SOA2. It is running as i can see pid from backend but health in console is showing not reacble. What could be the reason behind this.

Thanks
3 years ago
Hi Morris

Many many thanks to you. Your hint has really helped me. I got this issue sorted out now. Thanks a ton. You helped me a lot. Because of you guys we are getting a lot to learn. Thank you sir so much.

Workaround steps.

I went to /u01/oracle/config/domains/soadomain/servers/AdminServer/data/store and took backup of folder diagonistics and default and deleted the existing one. Then i deleted the tmp and cache folder also of admin server after backing it up.

and attempted to restart admin server and it came up.

Thanks Thanks Thanks sir once again
3 years ago
Hi Morris,

How to check this. Please tell me the steps as i have just extended my domain for soa suite. Did nothing else.

Thanks
3 years ago
Probably you are having problems acceding (NFS?)

Unable to understand how to find if i have problems acceding. Please let me know the steps to rectify this. Thank you so much for writing back on this.

Regards
3 years ago
Hi Morris,

Can you please tell me how to check this. I was able to access admin console before domain extending to SOA. But after i extended my domain to soa suite i started getting this error. Can you please tell me where to check for persistant store.

Thanks
3 years ago
Hi Team, I configured weblogic 12.2.1.3 and tried starting adminserver, but in backened i got below error. My server state went to running state, but i am unable to open admin console, but my em console is opening. The error i got in backened is



<Sep 24, 2018 2:16:57,792 PM GST> <Error> <Deployer> <BEA-149607> <Failed to persist state for deployment with name consoleapp. weblogic.management.ManagementException: [Deployer:149612]Problems were encountered while saving to the persistent store for "AppRTState[appId=consoleapp,retireTimeoutSecs=-1,retireTimeMillis=-1,

Module(s) State:{ROOT_MODULE={AdminServer={AdminServer=TargetModuleState[ModuleId=ROOT_MODULE,TargetName=AdminServer/*,State=STATE_FAILED}}},

AppTarget(s) State:{AdminServer=weblogic.management.deploy.internal.AppTargetState@74816612(appName=consoleapp, target=AdminServer, state=null, stagingState=-1)}]".

weblogic.store.PersistentStoreException: [Store:280039]The store handle 0 is not valid.

       at weblogic.store.io.file.BaseStoreIO.create(BaseStoreIO.java:441)

       at weblogic.store.io.file.BaseStoreIO.update(BaseStoreIO.java:516)

       at weblogic.store.internal.UpdateRequest.run(UpdateRequest.java:42)

       at weblogic.store.internal.StoreRequest.doTheIO(StoreRequest.java:100)

       at weblogic.store.internal.PersistentStoreImpl.synchronousFlush(PersistentStoreImpl.java:1249)

       at weblogic.store.internal.PersistentStoreImpl.run(PersistentStoreImpl.java:1233)

       at java.lang.Thread.run(Thread.java:748)





<Sep 24, 2018 2:39:13,095 PM GST> <Error> <Deployer> <BEA-149231> <Unable to set the activation state to true for the application "consoleapp".

weblogic.utils.ErrorCollectionException:





There are 2 nested errors:





java.lang.NullPointerException

       at weblogic.deploy.internal.targetserver.state.ModuleTransitionTracker.failedTransition(ModuleTransitionTracker.java:157)

       at weblogic.application.internal.flow.ModuleListenerInvoker.failed(ModuleListenerInvoker.java:230)

       at weblogic.application.internal.flow.ModuleListenerInvoker.activate(ModuleListenerInvoker.java:118)

       at weblogic.application.internal.flow.ModuleStateDriver$2.next(ModuleStateDriver.java:212)

       at weblogic.application.internal.flow.ModuleStateDriver$2.next(ModuleStateDriver.java:207)

       at weblogic.application.utils.StateMachineDriver$ParallelChange.run(StateMachineDriver.java:83)

       at weblogic.work.ContextWrap.run(ContextWrap.java:46)

       at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:670)

       at weblogic.invocation.ComponentInvocationContextManager._runAs(ComponentInvocationContextManager.java:352)

       at weblogic.invocation.ComponentInvocationContextManager.runAs(ComponentInvocationContextManager.java:337)

       at weblogic.work.LivePartitionUtility.doRunWorkUnderContext(LivePartitionUtility.java:57)

       at weblogic.work.PartitionUtility.runWorkUnderContext(PartitionUtility.java:41)

       at weblogic.work.SelfTuningWorkManagerImpl.runWorkUnderContext(SelfTuningWorkManagerImpl.java:644)

       at weblogic.work.ExecuteThread.execute(ExecuteThread.java:415)

       at weblogic.work.ExecuteThread.run(ExecuteThread.java:355)



Thanks
3 years ago
Hi Team,

I am setting up weblogic 12.2.1.3, for which the architecture i am following is

I have two host2. HOST1 and HOST2. In both host we have common shared mount point, which is /u01. So when i am loggin in both hosts i am able to access shared storage /u01.
In both hosts, HOST1 and HOST2 there is a local mount point in each which is /u02.

I have installed weblogic in shared mount point /u01. After installing weblogic, i created the domain in /u01 shared mount point. I am following per nodemanager per host concept. For which i have created nodemanager.properties file in both hosts /u02 mount point as /u02 is local to both machines. I did nmenroll also to the domain. I did pack and unpack of domain from /u01 shared storage to both hosts /u02 mount point. I started admin server, and able to start WLS_WSM1 from admin console. I am able to start WLS_WSM2 from admin console also, but state of WLS_WSM2 is showing not reachable which i have attached in this forum.

While checking the logs of WLS_WSM2 i found below error. I am unable to rectify that error. Please help me to get this resolved.

<Sep 24, 2018 9:57:14,802 AM GST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to ADMIN.>
<Sep 24, 2018 9:57:14,931 AM GST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RESUMING.>
<Sep 24, 2018 9:57:14,954 AM GST> <Error> <RJVM> <BEA-000580> <Failed to send JVMMessage from: '2758129357046954595S:dbpdcpciapvn574:soadomain:WLS_WSM2' to: '-3438674907617629430S:172.31.205.141:[7001,-1,-1,-1,-1,-1,-1]:soadomain:AdminServer' cmd: 'CMD_IDENTIFY_REQUEST', QOS: '101', responseId: '-1', invokableId: '-1', flags: 'JVMIDs Sent, TX Context Not Sent, 0x0', abbrev offset: '171'.
java.io.IOException: Attempt to send message on closed socket
java.io.IOException: Attempt to send message on closed socket
       at weblogic.rjvm.t3.MuxableSocketT3$T3MsgAbbrevJVMConnection.sendMsg(MuxableSocketT3.java:817)
       at weblogic.rjvm.MsgAbbrevJVMConnection.sendOutMsg(MsgAbbrevJVMConnection.java:389)
       at weblogic.rjvm.MsgAbbrevJVMConnection.sendMsg(MsgAbbrevJVMConnection.java:223)
       at weblogic.rjvm.MsgAbbrevJVMConnection.sendMsg(MsgAbbrevJVMConnection.java:173)
       at weblogic.rjvm.ConnectionManager.findOrCreateConnection(ConnectionManager.java:1742)
       Truncated. see log file for complete stacktrace


Thanks
3 years ago
Hi Tim and Morris,

Thank you for helping me in that. I was adding virtual ip instead of physical ip of the server. I am able to start it now. Thanks for the quick help.

Regards
3 years ago
Hi Team,

I have installed and configured weblogic 12.2.1.3 in linux 7 env. For my physical host i have got one VIP which i had used as listen address while configuring my weblogic

While starting admin server it got failed with below error

.>
<Sep 22, 2018 10:32:23,383 AM GST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to ADMIN.>
<Sep 22, 2018 10:32:23,470 AM GST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RESUMING.>
<Sep 22, 2018 10:32:23,471 AM GST> <Notice> <JMX> <BEA-149535> <JMX Resiliency Activity Server=All Servers : Resolving connection list DomainRuntimeServiceMBean>
<Sep 22, 2018 10:32:23,791 AM GST> <Error> <Server> <BEA-002606> <The server is unable to create a server socket for listening on channel "Default[iiop]". The address 1
72.22.211.189 might be incorrect or another process is using port 7001: java.net.BindException: Cannot assign requested address>

<Sep 22, 2018 10:32:23,792 AM GST> <Emergency> <Security> <BEA-090087> <Server failed to bind to the configured administrator port. The port may already be in use by an
other process.>
<Sep 22, 2018 10:32:27,126 AM GST> <Critical> <WebLogicServer> <BEA-000362> <Server failed. Reason: null>
<Sep 22, 2018 10:32:27,127 AM GST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED.>
<Sep 22, 2018 10:32:27,128 AM GST> <Notice> <WebLogicServer> <BEA-000382> <A critical service failed. The server will automatically transition to the ADMIN state.>
<Sep 22, 2018 10:32:27,132 AM GST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to ADMIN.>
^C

If i see my config.xml i am i am seeing the listen address is given as 172.22.211.189 which is the VIP of my hostname. Pl suggest where it is going wrong. As per oracle documentation they suggest to add VHN there. If i give VIP and not VHN i donot think it can affect anything. Still wondering what could be the reason.

Thanks
3 years ago