Aziz Rupawala

Greenhorn
+ Follow
since Dec 21, 2018
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
1
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Aziz Rupawala

so this My controller :



so when the following link gets triggered when the form is subbmited  http://localhost:8080/[Project name]/uregistration it gives the following message in console:
and the browser displays a

HTTP 405 Method not allowed error


So how should I fix this ? please help. Also if any other cod eis required please comment below.
1 year ago
ok so now the issue has been resolved it was a silly mistake, I had to do a small edit in the spring-config.xml file i.e I had to change to   and that's it.
1 year ago

Daniel Demesmaecker wrote:If you rather use Spring, be a bit more patient, there are a lot of "oldtimers" here on the site that surely can help you with your configuration


Well yeah I've been waiting but nobody is replying. I'll have to wait a bit more it seems.
1 year ago
Alright Thankyou very much I'll try this out If I have any problems I'll ask.
1 year ago
Alright, you can post that I'll try the code if no one posts a reply. Also if possible please tell me what changes I'll have to make.
1 year ago
well I recently got started with spring and I don't know anything about spring boot frankly speaking.
1 year ago

Daniel Demesmaecker wrote:Did you copy that config or write it yourself? Of seems weird to me not to put your jsp's in your WEB-INF, but you configurated it that way., zo it shouldnt be a prob. In springboot you have to put your config, so your application.properties, in your resources root, following that logica, I would move your config files.
I think, but once again i dont use XML, this line means the same
.
But maybe I should stop confussing you, since I dont really know and just wait till someone more familiar with XML config comes a long

If there are a lot of typo's, Im on my phone and have Dutch autocorrect on. I dont always notice when he changes something


well talking about if  I copied the config file then yes, but I have done the required changes but I guess I've missed something in the config file, hence the code ain't working.
1 year ago

Daniel Demesmaecker wrote:Warnings dont make your app fail. So you just get a 404?

yes that's what I got. there are no errors in the project.
1 year ago

Daniel Demesmaecker wrote:Could you post your stacktrace, since what you posted isn't your error, but your server starting up


Actually I'm not getting any error i'm getting following warning  after running the application i.e.  Also Thankyou very much for you assistance.

1 year ago
I tried as you said above but it still won't work.
1 year ago
here's my web.xml file:



spring-config file :




controller :



And after running the code her's what i'm getting



so how should I fix this ? please help!
1 year ago