Rachit Trivedi

Greenhorn
+ Follow
since May 03, 2019
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Rachit Trivedi

Yesterday I cleared my OCA Java SE 8 Programmer 1 test with 92%.

I have recently achieved my Masters in Computer Science degree. During my Masters program, I frequently used to write code in different programming languages (mainly in Java and Python). So, I was pretty much familiar with Java syntax, but didn't know about few concepts, like when and how to use "static" keyword, why should we use interface instead of abstract methods, etc. I decided to go with OCA Java SE 8 certification exam in order to make my core concepts stronger. While preparing for this exam, I felt that my Object-Oriented Programming concepts were becoming really stronger than before and I was learning new concepts which I have not used in my projects before. For example, I learned about lambda expression and how to work with predicate interface, static and default methods in interface, difference between checked and unchecked exception, etc.

I started my preparation with OCA Java SE 8 study guide by Jeanne Boyarsky and Scott Selikoff. This book was really helpful for me and the authors explain each and every concept with a set of small coding examples. When attending review questions, I was not getting a good score. So, I decided to read every chapter once again (as suggested by most of the people in this forum) as I was not performing good in review questions. Reading second time was a bit easier for me and I was focusing more on important topics. At this time, I decided to attempt the questions from OCA/OCP Java SE 8 Programmer Practice Tests (book by the same authors) instead of attempting the same review questions once again. This book was also a great source for practice as there were around 50 questions from each chapter. I was getting a good score (of around 70 to 80%) while solving those questions.

At last, I decided to take Enthuware exams (just before a week from my actual exam date). Enthuware exams were much harder than the real exams. I took a couple of standard tests from it and these are my scores of these tests:

Foundation Test: 78 %
Test 1: 84 %
Test 2: 83 %
Test 3: 71 %
Test 4: 96 %
Test 5: 84 %
Last Day Test: 83 %

Actual Test: 92 %

I was taking around 5 to 10 minutes in addition with 2 hours 30 minutes to complete Enthuware exams. I used to review the explanation of each and every question (irrespective of whether I answered correctly or not) and those explanations also helped me a lot. Well, I used to spend around 3 to 4 hours for reviewing each exam and for clearing the misunderstood concepts.

In overall, it was a fun for me preparing for this exam and I really enjoyed learning new concepts in Java.
1 month ago
Thanks for your quick reply. In here, I am copying the whole question with answer, it is from review questions of the chapter:

Which are methods using JavaBeans naming conventions for accessors and mutators?
(Choose all that apply)
A. public boolean getCanSwim() { return canSwim;}
B. public boolean canSwim() { return numberWings;}
C. public int getNumWings() { return numberWings;}
D. public int numWings() { return numberWings;}
E. public void setCanSwim(boolean b) { canSwim = b;}

This is the answer for the same question:

A,C, E.
Option A is correct because the property is of type boolean and getters must begin with is for booleans. Options B and D are incorrect because they don’t follow the naming convention of beginning with get/is/set. Options C and E follow normal getter and setter conventions.

Following is the link for the posted around 2 months ago. It was for the same question (but in different context).
https://coderanch.com/t/706490/certification/Chapter-Review
I am using OCA Java SE 8 study guide by Jeanne and Scott. In chapter 4 question 9, the answer is A, C, E. I am agree C and E, but didn't understand how A is correct. Table 4.5 says that, the naming convention for boolean return type must be start with "is". So, the method name should be "isCanSwim()", instead of "getCanSwim()".

Please let me know whether there is any mistake in book or my understanding is wrong. Any help will be appreciated.