This week's book giveaway is in the HTML Pages with CSS and JavaScript forum.
We're giving away four copies of Testing JavaScript Applications and have Lucas da Costa on-line!
See this thread for details.
Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!

archana kaul

Greenhorn
+ Follow
since Oct 01, 2003
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by archana kaul

Hi santosh
Thanks for the reply. I have done this already. I am copying the code here. I declared defined this fomrname and the required validation in validator.xml. Still it is not going to the javascript function in validation-rules.xml file. If you have any idea, pl. help me.
<%@ page language="java" %>
<%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>
<%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>

<html:html locale="true">
<body>
<html:form action="/Routing" onsubmit="javascript:validateRoutingForm(this);">
<html:text property="hello"/>
<br>
<td><input type="submit" value="Route Message"></td>
</html:form>
<html:javascript formName="RoutingForm"/>
</body>
</html:html>
16 years ago
Hi
I am also working in the struts. I am new to strutrs framework. I want to do client side validation. I have declared the fields and validatins requried for the fields in the validatin.xml. I am extending the
ValidatorActionForm for my formbean.
When I run the form by not entering anything in the form and press submit sutton, it is forwarding to failure page and it is not showing the required message.
What should I do to enable to client side validation. I have not written any javascript method in validator-rules.xml. All I am doing is defininf the errors.required in my application resources file. I am expecting a error message when I keep the text box blank. Can you please tell me what are the steps I need to follow to enable the validation.
Thanks,
Manjunath
16 years ago
Hi chris
I am also working in the struts. I am new to strutrs framework. I want to do client side validation. I have declared the fields and validatins requried for the fields in the validatin.xml. I am extending the
ValidatorActionForm for my formbean.
When I run the form by not entering anything in the form and press submit sutton, it is forwarding to failure page and it is not showing the required message.
What should I do to enable to client side validation. I have not written any javascript method in validator-rules.xml. All I am doing is defininf the errors.required in my application resources file. I am expecting a error message when I keep the text box blank. Can you please tell me what are the steps I need to follow to enable the validation.
Thanks,
archana
16 years ago
Hi karthik
Thanks for the reply. I have included taskdef element in the xml file. Now it is not giving the exception earlier, but it is giving different exception.
Buildfile: build.xml
build:
[mkdir] Created dir: E:\sample\build_dir
[copy] Copying 1 file to E:\sample\build_dir
No public execute() in class weblogic.webservice.servicegen
BUILD FAILED
file:E:/sample/build.xml:6: No public execute() in class weblogic.webservice.ser
vicegen
Total time: 0 seconds
The servicegen class file is present in the webservices.jar file in the weblogic server lib directory. I have just included it in the class path. I opened the code of the corresponding java file. It is not having the execute method. I cannot change this class as it is supplied by weblogic.
Can you tell me suggest me what to do?
Thanks,
archana
16 years ago
Hi I am new to web services. I want to make the ejb bean methods available to the remote client. I have created stateless session bean for this. I created the jar file and while creating the ear file I am getting the error.
I am using ant utility to create the ear file. I am attaching my build.xml here.
<project name="webServicesExample" default="build">
<target name="build" >
<delete dir="build_dir" />
<mkdir dir="build_dir" />
<copy todir="build_dir" file="trader.jar"/>
<servicegen
destEar="build_dir/trader.ear"
contextURI="web_services">
<service
ejbJar="build_dir/trader.jar"
targetNamespace="http://www.bea.com/examples/Trader";
serviceName="TraderService"
serviceURI="/TraderService"
generateTypes="True"
expandMethods="True" >
</service>
</servicegen>
</target>
</project>

When I run the ant command from the folder where this build.xml and the trade.jar files are present, it is giving the following exception.
Buildfile: build.xml
build:
[mkdir] Created dir: E:\web services\build_dir
[copy] Copying 1 file to E:\web services\build_dir
BUILD FAILED
file:E:/web%20services/build.xml:8: Could not create task or type of type: servi
cegen.
Ant could not find the task or a class this task relies upon.
This is common and has a number of causes; the usual
solutions are to read the manual pages then download and
install needed JAR files, or fix the build file:
- You have misspelt 'servicegen'.
Fix: check your spelling.
- The task needs an external JAR file to execute
and this is not found at the right place in the classpath.
Fix: check the documentation for dependencies.
Fix: declare the task.
- The task is an Ant optional task and optional.jar is absent
Fix: look for optional.jar in ANT_HOME/lib, download if needed
- The task was not built into optional.jar as dependent
libraries were not found at build time.
Fix: look in the JAR to verify, then rebuild with the needed
libraries, or download a release version from apache.org
- The build file was written for a later version of Ant
Fix: upgrade to at least the latest release version of Ant
- The task is not an Ant core or optional task
and needs to be declared using <taskdef>.
Remember that for JAR files to be visible to Ant tasks implemented
in ANT_HOME/lib, the files must be in the same directory or on the
classpath
Please neither file bug reports on this problem, nor email the
Ant mailing lists, until all of these causes have been explored,
as this is not an Ant bug.
Total time: 0 seconds

If anybody faced such type of problem, please help me.
Thanks
archana
16 years ago