Win a copy of Zero to AI - A non-technical, hype-free guide to prospering in the AI era this week in the Artificial Intelligence and Machine Learning forum!

Renuka G

Greenhorn
+ Follow
since Oct 30, 2003
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Renuka G

Hi All,
In a WAS 4.0.5. cluster( 2 nodes), have created a web and an ejb clone on each node. Created server group for web and ejb clones seperately.
And the workload policy, for both, is "round robin policy".
When i tested the sample app that comes with WAS, the web clones are load balanced correctly - alternated.
But for the ejb clones, for one web clone, it is alternating. But for the other, it is showing local ejb clone always. And the console error says:
"***Console Error/warning message goes here***
"WWLM0019: Method getNextClone found no usable proxies in the list. Current exception:
Message:
WWLM0019: Method getNextClone found no usable proxies in the list.
Stack trace:".
"***End of Console Error message ***
Need help please.
Regards,
Renuka
16 years ago
Thanks a lot, for the help Tony.
Regards,
Renuka
16 years ago
Hi All,
1. In WebSphere 4.0.5. server(Cluster), in the admin. console, there is a menu called "Ripple". Need to know under what circumstances(what types of changes to the groups/closes/nodes), this "Ripple" needs to be used?
2. In administering WebSphere 4.0.5. server(Cluster), when a change is made on one node, web server plug-in needs to be copied to other noded manually. Is there any other easy way, i can do this?
3. Under what circumstances(what types of changes), do i need to regenerate the web server plug-in?
Please help.
Regards,
Renuka.
16 years ago
Hi All,
After reversing the IP address change, now i can connect to the admin server. But when tried to start the server group in the cluster, got the error message:
***Start of error messages***
"Command "WebGroup.start" failed."
"Failed to access remote node "node2" during duplicate check for HTTP
transport port"
"CNTR0019E: Non-application exception occurred while processing method traverse: com.ibm.websphere.csi.CSITransactionRolledbackException: Transaction rolled back
at com.ibm.ejs.csi.TransactionControlImpl.getCurrentTransaction(TransactionControlImpl.java:519)
at com.ibm.ejs.container.EJSContainer.getCurrentTx(EJSContainer.java:1059)
at com.ibm.ejs.container.EJSContainer.preInvoke(EJSContainer.java:1610)
at com.ibm.ejs.sm.beans.EJSRemoteBMPRelation.traverse(EJSRemoteBMPRelation.java:608)
at com.ibm.ejs.sm.beans._Relation_Stub.traverse(_Relation_Stub.java:1971)
at com.ibm.ejs.sm.beans.EJBServerBean.getContainingObject(EJBServerBean.java:272)
at com.ibm.ejs.sm.beans.LiveRepositoryObjectImpl.getActiveObjectContainmentPath(LiveRepositoryObjectImpl.java:255)
at com.ibm.ejs.sm.beans.LiveRepositoryObjectImpl.initializeConfig(LiveRepositoryObjectImpl.java:613)
at com.ibm.ejs.sm.beans.ServerBean.initializeConfig(ServerBean.java:522)
at com.ibm.ejs.sm.beans.EJBServerBean.getConfig(EJBServerBean.java:414)
at com.ibm.ejs.sm.beans.LiveRepositoryObjectImpl.startSelf(LiveRepositoryObjectImpl.java:649)
at com.ibm.ejs.sm.beans.LiveRepositoryObjectImpl.start(LiveRepositoryObjectImpl.java:81)
at com.ibm.ejs.sm.beans.EJSRemoteBMPEJBServer.start(EJSRemoteBMPEJBServer.java:469)
at com.ibm.ejs.sm.beans._EJBServer_Stub.start(_EJBServer_Stub.java:1301)
at com.ibm.ejs.sm.beans.ServerGroupBean.start(ServerGroupBean.java:918)
at com.ibm.ejs.sm.beans.EJSRemoteBMPServerGroup.start(EJSRemoteBMPServerGroup.java:473)
at com.ibm.ejs.sm.beans._EJSRemoteBMPServerGroup_Tie._invoke(_EJSRemoteBMPServerGroup_Tie.java:549)
at com.ibm.CORBA.iiop.ExtendedServerDelegate.dispatch(ExtendedServerDelegate.java:532)
at com.ibm.CORBA.iiop.ORB.process(ORB.java:2395)
at com.ibm.CORBA.iiop.OrbWorker.run(OrbWorker.java:186)
at com.ibm.ejs.oa.pool.ThreadPool$PooledWorker.run(ThreadPool.java:104)
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:138)
"
***End of error messages***
The server was OK after the initial setup/installation/configuration. It was running fine for few months(it was idle). When the IP address was changed recently, had to restart the server machines.
Please note that i can start the application servers individually on the local node. When tried to start the application on the remote node, getting error message.
Need your help please.
Thanks and regards,
Renuka
16 years ago
Hi Kyle Brown,
Ooopps! I think i have been mislead by the gentleman who installed WAS at our site.
During the installation of IBM's HTTP server and WAS, we did not specify IP address except for the database server to persist the session data.
Please note that there is no change to the database server's IP address. Only the WAS machines' IP address was changed. And each WAS machine is housing both - HTTP server and WAS.
Still, need to re-install?
Thanks and regards,
Renuka
16 years ago
Hi All,
We are running WAS 4.0.5 in clustered Solairs boxes and are YET to deploy an application(except sample application). Installation and configuration was done by IBM's subsidiary.
After the installation and configuration, for security reasons, we needed to change the IP addresses of WAS nodes from public to private. After this, the machine was rebooted.
Now the problem is :
--------------------
When tried to run the admin. server, got error messages:
"[IBM][SQLServer JDBC Driver] Broken Pipe" and followed by
"Failure to create datasource:java.sql.SQLException".
Because of this, could not run adminclient.sh and hence could not run start the sample applications.
Please note that the session data is persisted in the SQLServer(7.0) database.
Need your help please.
Thanks and regards,
Renuka
16 years ago
Mahesh,
You are right - in Windows. But i am not sure about the Sun Solaris Box.
16 years ago
Hi All,
We are using Foundry Switch(ServerIron 16 Port) as a load balancer for web requests.
My question is : Is it the same as Network Dispatcher? IP Sprayer? If different, how? How does it differ from IBM's EDGE components?
Thanks and regards,
Renuka
16 years ago
Does it mean that we need to have larger RAM? Else, ending up using precious RAM resources?
16 years ago
Because of EJBs' distributed nature, any EJB from one location can call any EJB from another location and the location is transparent.
In my example, i am using JDBC resource and accessing it thru the JNDI. If it is an EJB access thru JNDI, i do not know how the EJBs are located internally... because during the JNDI entry configuration i made, EJBs JNDI names are not prefixed with DNS name/IP Addresses. Then, how are the EJBs located?
Need help/advise to refine my understanding in this regard.
Thanks and regards,
Renuka
16 years ago
Mahesh,
After that,
Now, i am getting the message:
"Component-managed authentication alias not specified for connection factory or datasource ds1."
Is this OK/normal? Or do i need to configure further anything? Thought it is meaningful for EJBs only???
Thanks,
Renuka
16 years ago